Black Screen Using Switcher

I share a monitor with my PC Windows/Linux and my Mac mini. I use a Greathtek switcher to switch between the two. Linux is installed on its own SDD in the PC and I go into it from the boot menu. After installing Zorin Pro, previously using PopOs, when I switch back to the linux after going to the Mac I get a black screen that I can't get out of. I can hear the audio playing in Linux but the screen won't come back. Just today I updated the settings to use the Nvidia drivers to try and fix it but it made no difference. Any suggestions?

In Settings > Power, please ensure that the setting to turn screen off when inactive is set to Never.

Are you set to different resolutions within the three different OS's accessing this monitor?

I just tried matching the resolutions and it makes no difference. Changing the power saving settings made no difference either.

What graphics are you using?

sudo lshw -C video

I recommend against the Nvidia 535 Proprietary driver at this time.


xset -dpms

to display Power Saver for monitors and test...

Does your BIOS /EFI settings include anything like "IGPU Multi-Monitor" or "Primary Display"?

I was using the other driver prior to Nvidia, I can't recall the name of it off the top of my head. I'm running an Asus 4060 vid card. Using the previous driver made no difference. I switched it to the Nvidia driver to try and fix the problem. I didn't see anything in the bios about the monitor/display.

Probably Nouveau.

Launch Software & Updates and navigate tot he Additional Drivers tab to check the drivers.

Yes it was previously nouveau and now using Nvidia. It was doing the same with the other driver though. Did some googling and apparently this is a many years old issue that still crops up. This is my primary issue with linux in a nutshell.

I checked in Settings > About> and it shows llvmpipe (LLVM 12.0.0, 256 bits) as the driver, no Nvidia. It says secure boot may be the problem, but as far as I know that has to be enabled for Windows, which I run on a separate drive.

I hear you... though I already know all too well about similar years old issues on Windows, including with Nvidia.

If Secure boot is enabled in the BIOS, this is a Motherboard setting. It won't make a difference which drive Windows is on.
Is Secure Boot enabled in your BIOS Security settings?

Disabled secure boot in bios. Changed drivers back to nouveau, restarted, boot back to Zorin, select Nvidia drivers, and now it won't boot into Zorin. It goes through the startup stuff but when it gets to the point where Zorin should open.... nothing. I'm not sure if it's because the Nvidia drivers won't install or it's something else. Turned secure boot back on in bios and it boots into Zorin, but the drvers are still listed as llvmpipe (LLVM 12.0.0, 256 bits). I sent an email to support. My experiments with linux are coming to an end I think.

Which Nvidia driver did you select?

What kernel are you currently on?

uname -r

If it is the 5.15.0-84 or lower, try a newer kernel:

sudo add-apt-repository ppa:tuxinvader/lts-mainline

sudo apt update && sudo apt install linux-generic-6.03

Once done, select the Nvidia 525 (proprietary) driver. Reboot and test.

It was on kernel 5.15.0-84-generic, so I did the update. There are two Nvidia drivers. One is 'Open kernel Nvidia-driver-535-open (proprietary tested)'. The other is Nvidia-driver-535 (proprietary). The last is the Nouveau. I tried all 3 after the update and the result is the same. After changing the driver is does ask for a password for secure boot. It never asks me to enter it again after that, but if secure boot is off in bios Zorin doesn't load.

Secure Boot notoriously interferes with Nvidia on Linux.
The problem is that GnuLinux cannot sign its own packages for Microsoft.
Microsoft must sign off on them. And while they do for most, they don't always get around to it...

Removed Nvidia drivers, with DDU, disabled secure boot, and after all that it wouldn't even boot with the Zorin drive connected. It wouldn't even let me boot into bios. I'm done with linux. I've tried for 4 or 5 years to utilize it, tried PopOs and Mint, but something always comes up, or there's a software compromise I'm not willing to make. Thanks so much for the help, but it's too frustrating to deal with. Thanks again.

Your frustration is completely understandable.

I admit - I have had this same issue with Windows. If it was not one problem, it was another - solving it led to a new problem. Contacting support led to the run-around with the usual "We do not support such and such hardware" copout.
It's computing. Complex devices with complex software... everyone's experience will be different. And everyone will experience breakage.

Hopefully you can get things working on an operating system that fits all your needs soon.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.