Black screen when installing Zorin OS 16.2 Core

Hi all!

I am having problems installing Zorin OS 16.2 Core. When I select any of the "Try and Install" options and press enter, the screen goes completely black.

I have a Windows 10 installed on this PC with UEFI, with Intel and AMD GPU's. I have disabled Secure Boot. Motherboard BIOS at the newest version. I am attaching system info below.

If anyone could suggest something, many thanks in advance :raised_hands:

Copy-pasting text summary:

CPU:           Intel Core i5-12600K (Alder Lake-S 641, C0)
               3700 MHz (37.00x100.0) @ 3600 MHz (36.00x100.0)
BIOS:          F21, 11/16/2022
Chipset:       Intel Z690 (Alder Lake-S PCH)
Memory:        32768 MBytes @ 1200 MHz, 17-17-17-39
               - 16384 MB PC28800 DDR4 SDRAM - Kingston KF3600C16D4/16GX
               - 16384 MB PC28800 DDR4 SDRAM - Kingston KF3600C16D4/16GX
Graphics:      Intel UHD Graphics 770 (Alder Lake-S 881 GT1) - Integrated Graphics Controller [GIGABYTE]
               Intel UHD Graphics 770, 1024 MB 
Graphics:      ASUS TUF RX 6800 GAMING OC
               AMD Radeon RX 6800, 16384 MB GDDR6 SDRAM
Drive:         GIGABYTE GP-GSTFS31256GTND, 250.1 GB, Serial ATA 6Gb/s @ 6Gb/s
Drive:         Samsung SSD 980 500GB, 488.4 GB, NVMe
Sound:         Intel Alder Lake-S PCH - cAVS (Audio, Voice, Speech)
Sound:         ATI/AMD Navi2x - High Definition Audio Controller
Network:       Intel Wi-Fi 6 AX201 160MHz
Network:       Intel Ethernet Controller I225-V
OS:            Microsoft Windows 10 Professional (x64) Build 19045.2364

Hi and welcome to the forum.
I refer you to this post, although I see you have disabled Secure Boot etc. Before you install

Did you check the SHA256 checksum of the downloaded .iso with the published value to confirm it is not currupted?

Which USB creation tool did you use?
Balena Etcher has been problematic for some, so I prefer Unetbootin, whilst others use Rufus.

Hey, zabadabadoo. I just checked the sha256 sum again to be sure - it matches. I used Balena Etcher. Previously I used the USB Creator Tool from that Ubuntu has, as I was on Ubuntu. I had the same problem. Can there really be a problem with USB creation tools, maybe some of them don't load drivers correctly or something?

USB Creator tool may be preferable to Balena Etcher.

Have you tried a different USB stick?
Have you tried a different USB port?

Balena has a habit of wrecking USB sticks.

Hey, so I tried burning the .iso with Rufus. And another stick for luck.

I checked 2 values:

  1. Partition Scheme: I changed it from MBR to GPT
  2. Image mode: I left it at ISO.

The boot worked! I believe that previously I might've written the image with MBR. As I'm dual booting with Windows which is with UEFI, I need GPT, since that's what's compatible with UEFI. And you need UEFI in both.

Thanks for the suggestion to try out other burners and sticks! And responding to my question, I appreciate it.

Now onto encryption. Man, I hate manually encrypting drives. Shame Zorin doesn't offer encryption as dual boot. Only when you override the existing system. Is there a quick link I can follow for Zorin? I can ofc first Install Zorin and I'll reinstall Windows later, maybe that involves less hassle.

1 Like

Windows before Zorin is the normal sequence for dual-booting.

I would question the need to encrypt your drive, unless you are James Bond, as that often results in misery when things go wrong.

Some content re encryption in this thread may be of interest: Zorin not installing on second laptopDr - #4 by Aravisian

Yeah, well I don't need full disk encryption but at least have /home on a partition of its own and have that encrypted. I'm a software engineer and I have keys to systems, ssh, AWS and other keys, so no theoretical home intrusion can compromise those. I'll give it a go, I have sth in my mind.

Hi, For clarity which does not appear to have been mentioned for potential new dual-booters, space has to be made in the Windows partition. To ensure EFI is used this tutorial video is really good - no usb, no DVD, just the .iso!:

What about encryption truecrypt?
Lavabit was used from Snowden.
What happens that all secure software? Project died?

Hi - don't know if this helps or not but I have the same issue: [Zorin 16.2 install problem - #47 by GeordiePaul](https://My issue of a blackscreen when installing Zorin)

Ubuntu and Mint work perfectly fine on the same hardware and I feel its the Zorin logo splashscreen that kills the install -- hopefully it can be removed/addressed in 16.3?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.