Black screen when tryint to boot from a USB

Hello, guys. I'm currently using the W11 OS on a new computer and need help to change for Zorin OS 16.1 Core.

I'm getting a black screen when trying to boot from a USB on this computer. The USB is working fine and I'm able to access the Zorin boot menu when I access using my laptop but it doesn't work on the PC, after I enter the boot section and select the USB I get a black screen and noting happens. The PC is a SSD only, doesn't have a HDD.
I tried downloading others distros and the same problem happened to all of them. They work and are able to format my laptop but they're just in black screen on the PC.
I already tried to format de USB for fat32 and NFTS. I used the program Zorin recommends to make the USB bootable and also Rufus.
Changed the BIOS order to USB first, disabled the security mode on BIOS and didn't work as well.
I don't know what to do anymore lol. Any suggestions?

In the Grub Menu (Zorin Boot Menu) have you tried selecting "Safe Graphics"?