Blocking graphics card upgrade

When I install Zorin it works (apart from some melee flashes on screen during startup). The problem is that after I update the software to the lastest version also the graphics driver is updated (or another mode is selected, I don't know) and the screen only shows the melee screen with an arrow cursor. Needles to say, I can't use the system or login.

SO how do I block Zorin from changing the graphics driver?

PC: Old Acer 7750G (2010) with an AMD HD6650M

Thanks for any tips (newby user)

What graphics are you using? Nvidia? Built-in?

Or, can you post the terminal output of

inxi -F

Thank you far answering ...

As I wrote in the question .... I am using a laptop from 2010 with an AMD HD6650M graphics card.

The out put from inxi is:
System: Host: tofanello-Aspire-7750G Kernel: 5.3.0-40-generic x86_64 bits: 64 Desktop: Gnome 3.30.2
Distro: Zorin OS 15.2
Machine: Device: laptop System: Acer product: Aspire 7750G v: V1.07 serial: N/A
Mobo: Acer model: JE70_HR serial: N/A BIOS: Acer v: V1.07 date: 03/02/2011
Battery BAT0: charge: 3.1 Wh 16.0% condition: 19.4/48.8 Wh (40%)
CPU: Dual core Intel Core i5-2410M (-MT-MCP-) cache: 3072 KB
clock speeds: max: 2900 MHz 1: 808 MHz 2: 846 MHz 3: 896 MHz 4: 1170 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] Whistler [Radeon HD 6630M/6650M/6750M/7670M/7690M]
Display Server: x11 (X.Org 1.20.5 ) driver: radeon Resolution: 1600x900@60.31hz, 1024x768@60.00hz
OpenGL: renderer: llvmpipe (LLVM 9.0, 256 bits) version: 3.3 Mesa 19.2.8
Audio: Card-1 Advanced Micro Devices [AMD/ATI] Turks HDMI Audio [Radeon HD 6500/6600 / 6700M Series]
driver: snd_hda_intel
Card-2 Intel 6 Series/C200 Series Family High Definition Audio Controller driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k5.3.0-40-generic
Network: Card-1: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet driver: atl1c
IF: enp2s0 state: down mac: 1c:75:08:f6:b2:50
Card-2: Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express) driver: ath9k
IF: wlp3s0 state: up mac: ec:55:f9:54:2e:e7
Drives: HDD Total Size: 480.1GB (1.6% used)
ID-1: /dev/sda model: JAJS300M480C size: 480.1GB
Partition: ID-1: / size: 439G used: 6.1G (2%) fs: ext4 dev: /dev/dm-0
ID-2: swap-1 size: 1.02GB used: 0.00GB (0%) fs: swap dev: /dev/dm-1
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 68.0C mobo: N/A gpu: 68.0
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 225 Uptime: 15:52 Memory: 1816.4/3917.3MB Client: Shell (bash) inxi: 2.3.56

I hope you can help.

Thanks rob

You have two monitors set up?

Can you list the terminal output of

xrandr --listproviders

To prevent a package from upgrading during a system upgrade, you can use the apt-mark command. For example, let's say you do not want the latest version of Gimp image editor, but you want to run the rest of your updates. You would run apt-mark hold gimp in terminal. Every package that can upgrade will - except gimp, in that case. The hold remains until you remove it with apt-mark unhold gimp.

I have never tried using apt-mark hold on a kernel... but you should be able to do so with

sudo apt-mark hold linux-generic linux-image-generic linux-headers-generic

Preferably, this would be a band-aid until a solution is found. I'm not sure, though, as the Kernel provides the AMD graphics drivers including amdgpu-pro. The amdgpu-pro will not work on older devices. It usually results in a segmentation fault and dumping the core.


I only have the PC monitor, there is no other one. This is the output of the xrandr commend:
Providers: number : 1
Provider 0: id: 0x48 cap: 0x0 crtcs: 6 outputs: 3 associated providers: 0 name:TURKS @ pci:0000:01:00.0

The only package I want to avoid is the AMD update ... but as you write that is part f the kernel update so probably difficult. I also tried Zorin 15.3 and 16 these do not even start.

So what are my options? Is there any?

thanks for taking an interest

best regards

You could try installing the AMD microcode:

There might be a few more options if you were using Hybrid Graphics (Intel and AMD).

In the meantime, holding the kernel back from upgrading may work for a while.

sudo apt-mark hold linux-generic linux-image-generic linux-headers-generic

And continue monitoring this thread for helpful members.

I have installed the AMD microcode. I assume the only way to know if it works is to just update ... true?

I have tried to stop the linux upgrade as you proposed and will run the software update to see if it works ... hope to cu on the other side :slight_smile: If not re-install and block software updater.

thanks for the support


But you do not need to do a Reinstall if it does not work. Hold the left shift key at boot up to enter the Recovery Menu and then boot from an earlier kernel.
OR adjust grub timeout

sudo nano /etc/default/grub

GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian

Set grub timeout to 10
Update grub before rebooting:

sudo update-grub

From the boot up Menu Screen if it appears for you; hit the Down arrow key to choose Advanced Options and from that menu, select to boot from the earlier kernel. Once on your desktop, you can remove the latest Kernel.