BlockstreamGreen-x86_64.AppImage won't start

BlockstreamGreen-x86_64.AppImage won't start on Zorin OS 12.4 64-bit. I set the read and write permissions and checked the execution of the file as executable. When I try to start with double click nothing happens. It doesn't even start from the command line. I use

sudo chmod +x BlockstreamGreen-x86_64.AppImage

in the folder of the file. Solutions?

First don't sudo chmod +x just chmod +x. It's a command that make hte file executable.

When made executable you should just double click the AppImage file to launch.

Download a new and try again. This time without sudo.

I downloaded again the appimage. I run in the command line chmod +x appimagename and then try to double click on the appimage file, but nothing happens...



the terminal show this

./BlockstreamGreen-x86_64.AppImage: /lib/x86_64-linux-gnu/ version `GLIBC_2.27' not found (required by ./BlockstreamGreen-x86_64.AppImage)
./BlockstreamGreen-x86_64.AppImage: /lib/x86_64-linux-gnu/ version `GLIBC_2.25' not found (required by ./BlockstreamGreen-x86_64.AppImage)
./BlockstreamGreen-x86_64.AppImage: /usr/lib/x86_64-linux-gnu/ version `CXXABI_1.3.11' not found (required by ./BlockstreamGreen-x86_64.AppImage)
./BlockstreamGreen-x86_64.AppImage: /usr/lib/x86_64-linux-gnu/ version `GLIBCXX_3.4.22' not found (required by ./BlockstreamGreen-x86_64.AppImage)
./BlockstreamGreen-x86_64.AppImage: /lib/x86_64-linux-gnu/ version `GLIBC_2.25' not found (required by /tmp/.mount_BlocksL48CJ2/usr/bin/../lib/
./BlockstreamGreen-x86_64.AppImage: /lib/x86_64-linux-gnu/ version `GLIBC_2.25' not found (required by /tmp/.mount_BlocksL48CJ2/usr/bin/../lib/
./BlockstreamGreen-x86_64.AppImage: /lib/x86_64-linux-gnu/ version `GLIBC_2.27' not found (required by /tmp/.mount_BlocksL48CJ2/usr/bin/../lib/

Strange, it should come with its own libs...

Anyway, try;

sudo apt install libm17n-0 libstdc++6

Can you give a link to the app you want to run?

this Blockstream Green: Simple and secure Bitcoin wallet

I try sudo apt install libm17n-0 libstdc++6 but but it's not solved

Works fine for me. What version of Zorin are you using?

Zorin OS 12.4 64-bit

Ah, that's very old. You need the latest of Zorin OS or any other Linux to run this app.

What's your computer specs?

xD i have a DELL XPS 13. Then I will update the version. Thank you

You can download the core here for free: Download - Zorin OS

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.