Blue tooth adapter not recognised -Zorin 15.3

From the Zorin Repository, yes.
As you are on Core...
Might I ask...
What is halting you from goin up to Zorin OS 16?

I tried it, felt too, uhh, dunno, homogenised maybe?
Too much like Windows?
In Core I can set it up the way I want using Tweaks - in 16, tweaks is castrated and my options are more limited.
I like the feeling of more subtle control Core gives me.
You know, sometimes you like a distro, sometimes. ... well I felt the same with the green one. (forget its name now)

1 Like

Also, I have about 6+ years worth of work store here, I run a separate home, and don't want the hassle of losing stuff in an upgrade.

1 Like

Anyway,coming back to headers, my reading of INTEL's site for the AX 210 suggests kernel 510 as minimum, so, in theory, should not the BT work also?

Seems the system is reading the INTEL BT card, I KNOW it worked previously so I am befuddled.

I have huge respect for you over the many years we have worked together, but, is the kernel really the issue?

As I understand it (And I almost posted this to @ajo001 earlier but was too lazy), the first kernel to have support was around 5.10. But it was spotty.
Then there were regressions.
For many, 5.10 worked and 5.11 did not.
5.12 did not.
5.13 did.

I do not know why. Maybe those in between kernels needed something that took a while to get to fix up what was spotty in 5.10.

Respect is fine, but do not take my word as The Final Authority.
I can be wrong.
I admit, on this one, I am confident that the kernel is the issue as nothing else can really make sense. I have been quite confident and wrong before. So please do pay attention to other suggestions offered.

You may try compiling from this git clone worked for someone else with similar issue. The thread is USB Wifi 5 -- BT + AC600 Driver free not functioning

The same driver may support multiple devices, so don't discount it (and you mentioned the same above).

1 Like

Ok, I was also looking back @ mrmagoo's suggestion, but I suspect he is not on Zorin as he talks about being able to upgrade to kernel 13

So summary is that despite everything, the current kernel is possibly not doing what we want? And I can't get any further than .11 - which I think is what I have?

As a top of my head - I need to check the kernel number installed again - BUT, if i went back to .10, assuming I have 11, might that be worth a try?

It is worth trying, yes.

You Can install higher than 5.11. Just not directly from the Zorin Bionic repo.

Zorin 16 is on 5.16.0-69

It may work. Reboot and hold shift so you can choose the advanced menu at grub, then select a previous kernel for boot. If it works we can make it permanent.

Upgrading to zorin 16 may resolve this issue without kernel customization.

Hiya @337harvey , long time no hear from.
That was my first idea, but then, does that not auto update very time Zorin updates?

First you confirm that it works. Then you can use apt-mark hold [package-name] to keep it from updating.

OK guys;
thx for that @337harvey turns out to me a moot point.

@Aravisian seems I jumped from 5.4 to 5.11- switching back to 5.4 of course, kills the AX210 card~

Can I share your banging wall?

While in the 5.4, tether to your phone and install the 5.10 kernel.... then [HOW TO] set an older kernel to default boot

You can use How to upgrade Zorin 16.2 to a newer kernel to install Ubuntu mainline, then install the 5.10 kernel.

Sorry, my mind is mush - how do i get a 5.10 kernel?
I read about it the other day, but now, ??

But hang on, when I was surfing the other day for updated kernels I found reference to download linux 15.? something at least.

So, is the catch here that they only run on Ubuntu 20 plus?

would this work?
Going to take my long overdue tea break now.
No hurry to reply.

In case the information is of any use here, I am on Z15.3 Core (but 64bit not 32bit). Last kernel update I received was 5.4.0-146 on 28/03/2023.

I might be late to this thread given the activity, but I have questions if you don't mind.

  • On plugin while running
    journalctl -f
    what is the output or relevant errors shown?

  • have you checked to see if the driver is loaded?
    lsusb -t
    will show you what drivers(if any) are recognized and loaded into the kernel and relevant to the usb device.

  • what drivers are in-kernel, are they the ones you installed?
    will show all drivers loaded into the kernel

  • after unplug/replug share the output of:
    systemctl --failed

That was me, and it's different hardware altogether, while that driver might work, the path to resolution is unclear, meaning I feel this is a guess, unless you're seeing something I'm not linking that git repo with the specific hardware?

Thx @geekdad - yes, different hardware etc, but, what ever you throw in the air, some might just stick - meaning maybe someone can take that and go forward with it. So thanks again for your input.