Blueetooth Audio Jitter - New topic?!


I have Version 16 Pro. Installed on one machine - all is well. Trying it on my HP Elitedesk and I am now experiencing the Bluetooth Audio Jitter issue that appears to be well discussed both here and across the internet.

  • I have tried all manner of the fixes suggested.
  • Installing Blueman
  • Changing settings in Pulse Audio
  • Changing settings in alsa-mixer
  • editing config files - using generic modules and turning off power saving.
  • adjusting offset

All to no success.

For the love of all that is holy - and I do love Zorin Linux - please can someone fix this, not just for me, but for all the other poor souls in my position. It seems ridiculous to me that whilst I am using Zorin successfuly for all my daily desktop needs - something as simple(?) as bluetooth audio may drive me away.
I do realise that this issue is larger than Zorin Linux, but you would hope that there would be a skilled guru who could come up with a solution.

If you have got this far - thank you for tolerating my ranting plea for help!

Yours in frustrated silence,

happy to post any logs / output if this may help anyone diagnose my issues.

1 Like

Can you please post the output of


Hi Aravisian,

Thank you for looking at this..

OUTPUT of lspci:

00:00.0 Host bridge: Intel Corporation 8th Gen Core Processor Host Bridge/DRAM Registers (rev 07)
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Desktop)
00:12.0 Signal processing controller: Intel Corporation Cannon Lake PCH Thermal Controller (rev 10)
00:14.0 USB controller: Intel Corporation Cannon Lake PCH USB 3.1 xHCI Host Controller (rev 10)
00:14.2 RAM memory: Intel Corporation Cannon Lake PCH Shared SRAM (rev 10)
00:14.3 Network controller: Intel Corporation Wireless-AC 9560 [Jefferson Peak] (rev 10)
00:16.0 Communication controller: Intel Corporation Cannon Lake PCH HECI Controller (rev 10)
00:16.3 Serial controller: Intel Corporation Cannon Lake PCH Active Management Technology - SOL (rev 10)
00:17.0 SATA controller: Intel Corporation Cannon Lake PCH SATA AHCI Controller (rev 10)
00:1b.0 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #21 (rev f0)
00:1f.0 ISA bridge: Intel Corporation Q370 Chipset LPC/eSPI Controller (rev 10)
00:1f.3 Audio device: Intel Corporation Cannon Lake PCH cAVS (rev 10)
00:1f.4 SMBus: Intel Corporation Cannon Lake PCH SMBus Controller (rev 10)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH SPI Controller (rev 10)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (7) I219-LM (rev 10)
01:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller SM961/PM961

I cannot find anything unusual about Cannon Lake Audio - everything should be in the kernel that it needs to run.
One thing that apparently can happen... Which I wonder about since you have tried all manner of fixes so far... The routers Wifi can interfere with bluetooth.
Sadly, the only way to test this is to try a different router...

Hi Aravisian,

Many thanks for getting back to me on this.
I will continue to investigate, if I find a solution I will post it here.

Thank you again,


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Marked Solution. 376