Bluetooth can't be enabled

Zorin seemed like a pretty decent OS so I figured what the hell, I'll support the devs and paid for the "Pro" version of the OS. However, I can't get Bluetooth to enable. I tried installing Blue Man and it terminates as soon as I tell it to turn BT on. From inside the settings, the toggle will switch but there's no response. Systemctl shows BT is active and running. Rfkill shows it's not blocked. I am coming from Pop!_OS where it worked perfectly. I am hoping to get this resolved ASAP so I don't have to refund this OS.

0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

First thing. Did you check the SHA256 checksum of the downloaded ZorinOS .iso against the published value before installing it?

What Bluetooth card or combined Wifi/Bluetooth card do you have?

To expand on this, @dmonger, in terminal please run

sudo lshw -C network

and post the output here.

1 Like

If sudo lshw -C network doesn't show any bluetooth, you could try sudo dmesg | grep -i bluetooth - will show if any drivers are loaded and if the device is present from the kernel.

Yes, I just double checked again. Checksum is the same. The combo card is the MediaTek MT7922. Sorry for the delay in responding I was expecting to get notifications of responses to this.

1 Like

Just did a websearch using " MediaTek MT7922 ubuntu 22.04" as Z17 is based on Ubuntu 22.04.
According to this link, it is certified:

I also found unanswerd questions on askubuntu about this device and driver.

I wonder if a later kernel would help, but others here may be better to advise.

description: Wireless interface
product: MEDIATEK Corp.
vendor: MEDIATEK Corp.
physical id: 0
bus info: pci@0000:02:00.0
logical name: wlp2s0
logical name: /dev/fb0
version: 00
serial: cc:5e:f8:82:ff:09
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm bus_master cap_list ethernet physical wireless fb
configuration: broadcast=yes depth=32 driver=mt7921e driverversion=6.2.0-39-generic firmware=____000000-20221227123243 latency=0 link=no mode=1920x1200 multicast=yes visual=truecolor wireless=IEEE 802.11 xres=1920 yres=1200
resources: iomemory:fc0-fbf irq:93 memory:fcf0200000-fcf02fffff memory:d0600000-d0607fff

zorin@zorin:~$ sudo dmesg | grep -i bluetooth
[ 34.597183] Bluetooth: Core ver 2.22
[ 34.597333] NET: Registered PF_BLUETOOTH protocol family
[ 34.597336] Bluetooth: HCI device and connection manager initialized
[ 34.597342] Bluetooth: HCI socket layer initialized
[ 34.597345] Bluetooth: L2CAP socket layer initialized
[ 34.597353] Bluetooth: SCO socket layer initialized
[ 36.313355] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 36.313361] Bluetooth: BNEP filters: protocol multicast
[ 36.313366] Bluetooth: BNEP socket layer initialized
[ 36.720368] Bluetooth: hci0: Opcode 0x c03 failed: -110

Have you yet run:

sudo apt update && sudo apt full-upgrade

Rebooted and tested Bluetooth?

Just did a fresh install, only one package was updated and had zero effect.

Please install blueman

sudo apt install blueman

Power on your BT device you wish to pair and set it to pairing.

Launch Blueman from the app menu and click setup and see if devices appear.

If your device appears, you can select it and click "Connect".

Installed Blueman, clicked connect when the prompt to enable automatically came up I selected yes. Blueman force closed and won't reopen even after a reinstall of the package

This is odd, since the driver and the init seem to be working. Have you tested that device on another machine?

Yes, the device has worked on different distros. It was just working on Manjaro previously to reinstalling Zorin

The only option in the Mainline repo was 6.6.8, which seems to be able to enable BT finally. Now I hope 6.6.8 is stable

1 Like

Now I just get to do this all again since I forgot to enable FDE during installation lol

@337harvey How I can upgrade kernel

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.