Bluetooth connection issue on Thinkpad t450

Hi! I'm having the same issue with my Thinkpad t450 trying to connect to my mi true wireless basic 2. As soon as a connection is established, the headphones restart (I can hear the sound they make when I turn them on, not the one for pairing mode)

I suspect bluetooth is sending something else because of an issue I have with another bluetooth device (the issue on that device is hard to explain and my English is not the best)... Is there a way to tell the driver to only send audio?

I just noticed I replied on the other thread... Sorry.

1 Like

Thanks for your time. That doesn't sound like my problem cause both devices connect successfully.
The headphones get stuck in a loop: pair, connect, restart, pair, connect, restart, pair, etc.

The other device connects and works as expected but it has a weird quirk:
It turns on at 50% volume (This is a factory setting) and I I have to turn the volume up with physical buttons.
I connect the device to the computer and play music with no issues, but, if I turn the volume up or down from the computer, the volume of the device goes back to 50%

I've never taken English lessons, I hope I'm making myself clear.

1 Like

If I check one of the devices with Blueman I can see this:

Let's say I want to disable the "Remote control target"... Is that possible? May be using its UUID.

That is something I would try on windows using the device manager but I have no idea how to do it on Linux (I forgot to say both devices worked on windows)

I've been on Linux one week BTW, I have no idea what I'm doing :smirk:

Hi, sorry for delay. See if this gets you any further. Be sure to read all of it.

So... I found this thread that describes both my problem and my suspected solution but I don't know how to apply it.

I was able to connect the headphones by disabling AVRCP by adding --noplugin=avrcp to the bluetoothd command line

Is this telling me to open a terminal and entering bluetoothd --noplugin=avrcp?

When I do that, I get this: D-Bus setup failed: Connection ":1.1902" is not allowed to own the service "org.bluez" due to security policies in the configuration file

So... What now?