Bluetooth Device not being detected

My bluetooth adapter isn't being detected. I've done a bit of troubleshooting but run into a wall and don't know where to go from here. I was using PopOS before and it worked in Pop so I know it is compatible with Linux. Here is the output of what I've tried, its worth noting that the modprobe needs to be run after rebooting my computer otherwise lsmod | grep bluetooth will return nothing:

I'm using Zorin 17 beta.

Welcome! :smile:

What machine are you using; make / model?

Also, can you post the output of rfkill list?

For the lsmod command, try sudo lsmod | grep -i bluetooth. '-i' ignores case, or capitol lettering - shows all.

1 Like

Thanks :slight_smile:

I'm using a desktop, the motherboard is MSI MPG B550I. The Networking hardware is the Intel AX200.

The output of those commands is as follows:

jam@jam-g1se:~$ rfkill list
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
jam@jam-g1se:~$ sudo lsmod | grep -i bluetooth
[sudo] password for jam:         

can you share the outputs of

dmesg | grep -i Blue
uname -r; lsusb; sudo dmesg | egrep -i 'blue|firm'

and also lshw -C

Also did you try sudo /etc/init.d/bluetooth restart , if not can you run this in terminal?


Lots of posts a bout the AX200/201 chips!

Here's some drivers you can check out; posted these with:

Intel forum post - one of the Intel reps suggests trying the AX201 driver for the AX200 chip. Apparently, and you can see in the posts, there were some revisions to the AX201 driver to support some of the AX200's.

This may be a 20.04 thing - like another issue with sound drivers I was trying to get going. 22.04 works with the sound drivers mentioned (essx8336) but, not with 20.04.. weird..

If those drivers don't work - might have to take a different route.

Thanks for the help guys, somehow it has started working again. I don't know why but thanks anyway :smiley:


If this is cleared up, can you mark the post / thread as 'Solved'? :grin:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.