Bluetooth doesn't work at all

Hello everyone, this post is translated with Google translator, it may contain some writing errors

I've had Zorin OS 17 for a while now, and recently bluetooth doesn't work. I was reading about how I can fix it but there is no solution. The problem is that the bluetooth is recognized by the computer and it turns on but does not connect to any device.

My computer was delivered by the government, it came with a system called Huayra and Windows, and I installed Zorin 16 and it was updated (obviously)

It is a SF20GM7 model computer.
This has an Intel Celeron 8th Generation and the bluetooh and wi-fi modules are by Realtek Semiconductor

I await your solution and I thank you in advance. <3333

Welcome to the Forum!

Maybe Your Government blocks Bluetooth for Security Concerns?

So, are You now on Zorin 17 or was that simply a normal Update for Z16?

I had Z16 and when the Z17 came out I updated it (formatting the disk and installing the new system), and at that time the bluetooth worked but recently it didn't.

Also, the government cannot (I think) block the module.

I was thinking that the best solution would be to reinstall Zorin.

A complete fresh Install could help, yes. When this is a Step that You can take without Problems it is an Option. Don't forget to save Your Data.

Did You tried Blueman? It is a Bluetooth Manager Program. You can install it with sudo apt install blueman and test if it works. And if not You can make a fresh Install.