Bluetooth losing connection

Hello I followed your instruction but when I want to close files it said I don't have permission to save changes to the files , and I entered command to terminal it said I am in root "mode"

Hi and welcome to the forum :slight_smile:

Since you are necromancing :skull:
3 month old thread in non-English language,
I will create a new thread for you.


Here we are.
This thread is all yours.

Please describe the problem you have with your Bluetooth along with which version of Zorin you are using.

Hello. I am using Zorin OS 16 core.So issue that I have is that my Bluetooth mouse when is connected works some time than stop, when I want to disable and enable Bluetooth interface will not enable Bluetooth again. I tried to do what Aravish suggested in terminal to type command sudo -i and than change lines in 2 files: /etc / NetworkManager/conf.d/default-wifi-powersave-on.conf wifi.powersave = 3change towifi.powersave = 2 and remove hashtag in following/etc/bluetooth/input.conf #UserspaceHID=true,UserspaceHID=true but when I want to close and save changes I got message I am not allowed to make changes

Hello Vlad, try it with;

sudo nano {path to file}

on both files

After adjusting the line use CTRL + x and then y

when you say path to the file you mine to type this in terminal after sudo-I? I am new to linux , so my questoin is maybe stupid :grinning:

Yes, but it's

sudo nano /etc.....

for both files.

it got me there but how to move inside this to get to the file and edit the line

Your doing alright there, but I believe this is not the right file, because the values you are suppose to mutate are missing. Close it (Ctrl +x and n).

Try again but use the full right path which is given by Aravisian,

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

it should lead to this output with the values present;

got it , I am in and now I just delete 3 and punch 2? how to save changes now and exit?

I described it above; CTRL + x then y. :wink:

Fixed :grin:

1 Like

It's ok , but I believe it would be read-only then, but I might be wrong.

same thing again works for a while and stop working, and when I go to bluetooth options it shows as mouse connected and when I want to disconnected will not allow and move back slide as connected same thing for headphones

cat /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

this is the respond I get when I type this in terminal: [connection]
wifi.powersave = 2

Can you please note all devices mac addresses.
Then, disconnect all Blue devices.


You will see a couple of prompts. First

agent on


default agent

Using your Mac addresses for your devices


Replace PLACEHOLDER with the mac address of the device




same thing worked for a while and stop working, shows mouse is connected in bluetooth setings

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.