Bluetooth shown active in terminal but not opening when in settings

Hello all, when i click on bluetooth or bt adapters nothing happens it wont open.. Please help make this work

You might need to just restart the service:

sudo service bluetooth restart

If that does not do the trick, you can try checking that the module prober spots it:

sudo modprobe -r btusb

sudo modprobe btusb

If that is still no good, check that it is not blocked:

rfkill block bluetooth

rfkill unblock bluetooth

Lastly... is this a Notebook Computer? If so, the battery saving feature may be interfering by limiting power consumption.
I would first install TLP to help manage battery drain. TLP simply works in the background. It does not have a GUI interface and needs no configuration.

sudo apt install tlp

Once done, now disable powersave on Radio:

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

You will see

wifi.powersave = 3

Change that to 2

wifi.powersave = 2

Tap ctrl+x to exit, then the ykey to say yes to save, thent heenter` key to save the current configuration.
Reboot and test.
If none of the above works, I wish I hadn't used all my material in the first post. :wink:

1 Like

Hello my friend, i tried all your suggestions and was not able to succeed unfortunately.

Have you got any other tricks up your sleeve?

I am running latest Zorin that i have installed on a Macbook pro laptop, intel.

So bluetooth isnt working, sound isnt working (dummy option only) and wifi works and then sometimes diappears. Restart doesnt help the widfi but shutting off does. Haha what a marvel. I installed Zorin os lite on my old windows laptop (dell) and it all works. Here on the Mac... well this is why im here :slight_smile:

That is quite a list...
When you installed on the Macbook, did you ever get the error Failed to set MokListRT: Invalid Parameter?

Hello again, sorry I've been away and haven't jumped online.

Right as I start the laptop this appears on left hand side of screen large, then large again, then small.
(attached image)

It's very fast but I managed to capture and this I get every time I start-up, followed by login screen.

The error you've mentioned I haven't seen, hope this helps some more, thank you for your time!!

Those errors deal with a different issue and can be safely ignored.
I also get the AE_NOT_FOUND error on boot. It is annoying to see it but... that is all it is.

Can you please check if Blueman is installed:

sudo apt install blueman

Launch blueman and relay a screenshot of View > Local Services

Hello sir!

Tried this before and same result. However I did it again and completes install asks to enable, then nothing happens. Go into setting and bt click on but nothing happens as shown on pic.

Doea not show up in task bar either :slight_smile:





Can you please run:

rm -r ~/.config/pulse; pulseaudio -k

sudo systemctl restart bluetooth

If that fails:

sudo apt install pulseaudio-module-bluetooth libusb-dev libdbus-1-dev libglib2.0-dev libudev-dev libical-dev libreadline-dev

pactl load-module module-bluetooth-discover

Here we go no luck

Does your computer have a button on it that turns on Airplane mode? Some manufacturers include that and if it is accidentally pressed... You may not realize it.
Also, you can check in your settings if airplane mode is enabled.

Nah aeroplane mode is off as Wi-Fi works also

Please be sure to check. Wifi can sometimes work even with Airplane mode on.
But bluetooth won't.
Wifi working has caused people to assume that airplane mode is off before...

I did check before I answered. :slight_smile:

1 Like