Blurred and scrambled video in VLC

Hello everyone have a great day :grinning:
This problem occurs every time I tried to play any 720p or higher resolution videos. But it only occurs in vlc, not in MPV, MPV plays the video without any issue. I am not a fan of MPV, So I don't want to use it.
If you guys know any solution It would be a great help

Have you installed all codecs?

sudo apt install ubuntu-restricted-extras


MPV is also a backend for other media players to use, so you could use GNOME-MPV for instance

either way, I would make sure codecs are installed, the quickest way I can think of to install Codecs would be running sudo apt install ubuntu-restricted-extras in a Terminal
This downloads some codecs (for MP4 and such) and also Microsoft's fonts, maybe that resolves your issue

Have a nice day in the meantime :slight_smile:

turns out he already did that, whoops

What method did you use to install VLC?

I Have installed all the codecs at the time of first boot

flatpak. I have tested both version from Zorin repro and flatpak . Both versions has same issue

In this case, the Ubuntu Restricted Extras will not help you, since the Flatpak or Snap will not recognize them.
If you installed fromt he Software Store, it will install as either Snap or Flatpak unless you disable them.
You may need to try an older version packaged as a .deb .

No, I have installed it from CLI apt install vlc and
then to check the issue I have purged it and installed flatpak version.
But it seems both version have the issue

1 Like

I have also checked older version of vlc (.deb) also but the issue is still there

1 Like

Have you tested Totem?

No, what is Totem?

Totem AKA gnome "Videos" : is this Totem?

No, I will try it and get back to you tomorrow. Because it is 10 pm here in India.

See you guys :grinning_face_with_smiling_eyes:

totem is good it plays the video perfectly fine, but lots of vlc features are missing.
But why is the vlc is acting this weird :thinking:

Yes, we have narrowed it down to just VLC.
I think the path is Tools > Settings > Video > Display. Not sure on that... but on a path like that, can you disable Accelerated video output (Overlay)?

cant find an option like that

I tried search instead of brain:

Already done that. But the issue persists :frowning_face: