Boot Error message after Installing Zorin 16 pro On Mac Mini 2012

Recently reinstalled zorin 16.1 pro on my mac mini 2012. At boot up, the following error message appears: " DMAR-IR Firmware Bug ioapic 2 has no mapping iommu, interupt remapping will be disabled. .....ACPI error: AE_AML-Operand_Type , while resolving operands for .... Any suggestions for how to correct this message?

You may need some additional Grub boot parameters.
Can you open terminal and run

sudo nano /etc/default/grub

Arrow key to the line
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
and add the parameters irqpoll and intremap=off
So that it looks exactly like:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash irqpoll intremap=off"

Tap ctrl+x to exit the editor, then the y key to say yes to save, then the enter key to save current configuration.
The terminal will return to normal. Now run

sudo update-grub

Reboot and test...

Thank you Aravisian for the quick response. I altered the grub parameters per your instructions and unfortunately the error messages still persists.. I've uploaded a screenshot of the error message. Any further ideas about how to proceed?

Pardon me, disregard the last screenshot: here's the latest image generated after altering the grub line per your instruction:

after editing the line all that remains are ACPI errors... =
What do you think?

Are you using Nvidia Graphics card?

No... The Mac Mini 2012 is using an on board intel video subsystem...

Intel HD Graphics 4000

Ah... Mac
The EFI may not be the same standard as that used by Ubuntu.
Or in this case, Zorin OS.
Updating your BIOS Firmware may solve the issue, if you are able.

Does Zorin OS boot and run normally, or do you have a black screen with blinking cursor?

It appears to be running ok. Out of curiosity, I did install Q4os on the same machine to see if that error appeared after a full install and update. It did not. Pop OS also installed without generating the same error. (Windows 10 also installed nicely without any difficulty or error too..) So I'm wondering why Zorin is provoking the appearance of that error. I really appreciate alot of the features present in Zorin and would prefer to use it over the other OS's if this issue could be resolved....

I'm gonna see if there is a firmware update available for this old machine... wish me luck...

1 Like

It may be the BIOS Firmware. Please bear in mind that installing BIOS updates can be more tricky as the vendors supply them as an .exe file for Windows.
You cannot use WINE to update BIOS.
So, if you find that you do need a BIOS update, please say so we can guide.

The issue you are having may be due to the kernel in use. Which seems possible given that distros running different kernels did not produce those error messages. We can try a different kernel and see if you get a different result.

You may also just need a kernel boot parameter in Grub:
pci=nommconf

sudo nano /etc/default/grub

Add pci=nommconf to the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" so that it looks exactly like: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nommconf"
Then ctrl+x to exit the editor, y key, then enter key to save current configuration.
Update grub to make the change take effect

sudo update-grub

If the parameter gives you any trouble, remove it to restore the line back to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" and be sure to run sudo update-grub again...

Keep in mind that the error you are seeing is a basic warning that is overridden upon init. Your system is running fine.
So at the end of the day, you can ignore or even silence the error warning, too.

How do I silence the warning?

...also, thank you for the feedback! I really appreciate it. I'm just a few steps above being completing ignorant :smile: in regards to things "Linux" so the help is greatly appreciated.

You can add the parameter loglevel=3 to grub to set it to only show important errors.
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash loglevel=3"

As I think about it... you might have some luck with using acpi=strict
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=strict"
It might be worth trying first if you have the patience.

Always be sure to run

sudo update-grub

after changing your grub file so that the changes take effect.

The "loglevel=3" parameter alteration worked! The error message no longer appears when I turned the computer on... Thank you for your assistance with this! It's greatly appreciated....
Thank you!