Boot manager doesn't recognize my pendrive

Is your system set up for legacy or efi?

Which iso writer did you use?

How old is your usb?

Have you ever tried using belena etcher?

It's EFI

WoeUSB and later unetbootin

No idea

Balena Etcher can burn Windows ISOs?

This is the same usb that you pulled when it was formatting?

Yes (5 characters)

Finicky, isn't it?

Things you can try:

  • Before you shut down, after you finish burning the USB stick, open your file manager and Mount the drive. Or you can Mount it using Disks. Then eject and shut down and try booting the USB stick as normal.
  • Try using a different USB stick.
  • Try using a different USB port.
  • Ensure that the USB stick is fully plugged in before ever hitting the power button to power on the computer.
  • If UEFI is not working, try booting in Legacy Mode.
  • If you have PPT setting in BIOS - disable it.
  • And, as always, ensure Secure Boot is OFF (you can turn it back on later for a Windows Machine).

Have you tried viewing it in disks in zorin? Did you attempt to reformat it in zorin?

Yes (5 characters)

Already tried almost all of those. I think i will buy a new pendrive


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.