Boot manager doesn't recognize my pendrive

I'm trying to make a bootable pendrive with windows 10, i'm using woeusb to make it but for some reason the boot manager doens't seem to recognize the pendrive even thought Zorin OS does recognize it in the file manager

I'm using Zorin OS 16 Core

Are you burning it as EFI?

You might try using a different etcher.

Ok, i managed to make a bootable pendrive, BUT windows 10 is too big for the FAT32 format so windows gives me a error and doens't let me install it

That is odd:

FAT32 is the correct format. Where did you get your copy of Win10 from?

From the official microsoft website

What size is your USB drive?
If it is too large then you can try using a smaller one, like a 16 gig.
There is an upper limit on how much drive space can be formatted in FAT32.

it's 8 gig

I'm stumped. But I am certainly not the best resource for Windows. Maybe @337harvey can help.

From what i searched there's a file called install.wim. that's too big for FAT32 so the Windows installation thingy gives me a error that says that the install.wim. file doens't exist and can't continue installation

You'll have to format it using ntfs... if you install wine you can use rufus which gives the option. But again i don't know if your drive is too small...i don't know the current size of the iso, but that's compressed. On a usb thumbdrive i'm thinking 6 to 8 gigs. You may need a 16gb drive.

I don't know if unetbootin allows for choosing the fs, but that may be an alternative.

I assume you mean here " Create Windows 10 installation media":

MS states you need 8gb or larger blank USB.

Are you trying to create your USB from Windows or ZorinOS? I have never tried the latter.

Already tried formmating with NTFS but the boot manager doens't recognize the pendrive. The ISO is 4.8 to 5.2 gigs, i'm not sure

From ZorinOS i have managed before to create a bootable pendrive on other distros

Everything looks right. The size, the formatting. It's no wonder you're stumped.
Which leads me to think there is likely something wrong with the drive itself. Most often, when you do everything right and are still stumped- The USB drive is flawed.

It may seem like the USB drive is still good

  • But I just used it last week, it was fine.
  • But it worked on Windows.

But the evidence is ^ It's not working.
Are you able to use a different drive and test?

1 Like

I have another one but i have no idea where it is. I think i know why it ins't working (maybe), before installing the Windows ISO i was formmating the pendrive via the ZorinOS file manager (Nautillus i think) and the file manager didn't give me any warning that it was formmating, so i removed it, and it gave me an error and after that the pendrive stopped working for some minutes, maybe it was because of that?

(Also sorry if my grammar is wrong, english is not my first language)

Entirely possible, yes.

I would check the integrity of the drive - at the very least, run it in gparted and format the drive in FAT32 completely. Beginning to end. Once done - Do it again. Three times if you have the stamina.
Then try burning your bootable ISO to it.

1 Like

Another solution: is a reputable site and their tutorial is quite trustworthy.


Do i burn the ISO in a NTFS partition or in a FAT32 partition?

You will have to use ntfs because fat32 doesn't support the size of the image file. The same thing is true with windows 1* (indicating 10 or 11).

If it doesn't default to ntfs, change it manually.

Still didn't appear in the Boot Manager