Boot time taking to long

My laptop is taking to long to boot, I can't figure out what is wrong. This are my laptop's specs:

this is the lsbk output:

nvme0n1     259:0    0 476,9G  0 disk 
├─nvme0n1p1 259:1    0   104M  0 part /boot/efi
├─nvme0n1p2 259:2    0  49,5G  0 part /
├─nvme0n1p3 259:3    0 370,3G  0 part /home
├─nvme0n1p4 259:4    0   8,3G  0 part 
├─nvme0n1p5 259:5    0    16M  0 part 
└─nvme0n1p6 259:6    0  48,7G  0 part 

the last partition (nvme0n1p6) of 48,7G have Windows 10 installed

The systemd-analyze output:

Startup finished in 10.915s (firmware) + 9.149s (loader) + 5.277s (kernel) + 1min 34.781s (userspace) = 2min 123ms reached after 1min 34.728s in userspace

systemd-analyze blame (partial) output:

3.837s plymouth-quit-wait.service
1.395s docker.service
1.327s fwupd.service
 754ms dev-nvme0n1p2.device
 481ms networkd-dispatcher.service
 397ms containerd.service
 322ms systemd-journal-flush.service
 311ms ubuntu-fan.service
 294ms udisks2.service
 274ms accounts-daemon.service
 262ms apparmor.service
 232ms systemd-oomd.service
 228ms systemd-resolved.service
 215ms systemd-logind.service
 209ms ModemManager.service
 200ms systemd-timesyncd.service
 197ms user@1000.service
 178ms e2scrub_reap.service
 178ms gpu-manager.service
 177ms systemd-udev-trigger.service
 171ms lm-sensors.service
 170ms polkit.service
 166ms power-profiles-daemon.service
 166ms power-profiles-daemon.service
 154ms preload.service
 152ms cups.service
 151ms switcheroo-control.service
 150ms upower.service
 149ms gdm.service
 149ms secureboot-db.service
 128ms systemd-udevd.service
 128ms avahi-daemon.service
 122ms systemd-fsck@dev-disk-by\x2duuid-DE0A\x2d0FF9.service
 121ms geoclue.service
 118ms grub-common.service
 114ms keyboard-setup.service

And systemd-analyze critical-chain output

The time when unit became active or started is printed after the "@" character.
The time the unit took to start is printed after the "+" character. @1min 34.728s
└─ @1min 34.727s
  └─plymouth-quit-wait.service @1min 30.887s +3.837s
    └─systemd-user-sessions.service @1min 30.859s +15ms
      └─ @1min 30.826s
        └─wpa_supplicant.service @1min 30.755s +70ms
          └─dbus.service @1min 30.679s
            └─ @1min 30.661s
              └─ @1min 30.661s
                └─docker.socket @1min 30.642s +18ms
                  └─ @1min 30.611s
                    └─systemd-timesyncd.service @1.869s +200ms
                      └─systemd-tmpfiles-setup.service @1.648s +85ms
                        └─ @1.569s
                          └─home.mount @1.502s +62ms
                            └─systemd-fsck@dev-disk-by\x2duuid-155d8044\x2d0832\x2d4ebd\x2d8c69\x2dfc9d881f994d.service @1.171s +89ms
                              └─dev-disk-by\x2duuid-155d8044\x2d0832\x2d4ebd\x2d8c69\x2dfc9d881f994d.device @1.123s

I already disabled NetworkManager-wait-online.service and got rid of snap
What else can I do to improve boot time?

Gday @Harry_A

Please check for UEFI firmware/driver updates,
Also run a SMART check on your drive,

Please make sure you have WIndows Fast Startup "Disabled",

With the above link, just Disable the windows Fast startup.
You could check you have Fast Boot "enabled" in you UEFI.

The stage thats taking time is i believe, after kernel & before graphics (OS), hence why i suggest the above things, is the laptop in a dusty area .. it may need a clean...
Hope this helps

I assume you know you could disable a few thing's like.. "plymouth-quit-wait.service",,"docker.service".."fwupd.service"
But thats not my suggestion as it's only a few seconds & can cause more issue's.

The main time hungry part is getting the OS to fire up, I don't see external drives,, (this can cause a similar effect).
let us know how you go.

Thank you for your answer, I already run the SMART check and was ok, this laptop it does not have yet even a year of usage. But it's probably the Windows Fast Startup thing, I installed Windows for a very specific way and I only have started like two times I think, I haven't change any from default. And probably it needs the clean dust is a problem in my area. I'm at work right now as soon I got a chance to check this I will expose the results

1 Like

I have disabled fast boot in Windows, but in BIOS I don't encounter enable and disable options instead I found three options for Fast Boot:

  • Minimal (basically cancel steps to better boot)
  • Thorough
  • I really don't remember the last one but it says that with that option the BIOS decide how to use fast boot

still my boot time is really slow up to 2 minutes
Thanks for the help, I wish could more helpful right now but is late night and I really tired

I have an old Dell laptop it takes approx 54sec to boot, just to show your not to bad @1.30min

Yes Fast boot in BIOS , "Minimal" is the correct setting.

Did you try to update the BIOS firmware?

I actually was expecting something like these

❯ systemd-analyze
Startup finished in 4.716s (firmware) + 13.075s (loader) + 1.974s (kernel) + 8.627s (userspace) = 28.393s reached after 8.587s in userspace

This is on my work desktop with Ubuntu 22.04, with the only difference that at work I have a SATA SSD, not NVMe like on my laptop and that both are Intel-i7, only that at work it is fourth generation and my laptop It is octave.

I do not think that this can account for a boot time of two minutes all on its own.
It is true that the SATA SSD will relay information more slowly, though, so you can expect a slower boot time with it. Not by that much, though. Those are HDD speeds you are displaying.

Have you checked your boot logs?

Something is inhibiting init early on.

Gday @Harry_A

Can you please tell us the Make And Model of the laptop.

Please let us know if you have updated the BIOS firmware?

Also when did this start happening?

Is this a new install of Zorin OS 17.1 or did you "Upgrade" from Zorin OS 17?

it maybe a kernel issue, you could also try rolling back the kernel.

Remember to back up, before any changes.

Can you screenshot "GParted" , i believe you may have Windows at the end of your drive..
I have had issue's with dual boot when Windows isn't the first partition.

If this is the case & you can backup your info,
I'd Start again,
Install Windows & let the ISO erase the drive & partitions by itself.
Install Zorin OS alongside windows.

As a side note: you mentioned "Octave", i've seen some info about MKL, once we know the Make & Model, we maybe able to determine if this is present, this may also create slow bootup.

Keep us informed.

The laptop is a Dell Latitude 5490

The BIOS firmware have the second to last version, released on decembre 2023

I upgrade from 17

I do have Windows at the end of the drive as I installed Windows after Zorin

I been thinking about a reinstallation for while now but I was having some issues with Timeshift also, so because of that I wasn't decided

I prefer the "Déjà Dup " app, it's faster, i tried the timeshift once & from memory it was approx 40hr,s to run the backup for 100gb of data, i believe it ran for about 5-6hrs & i gave up on it.
I've used Déjà Dup about 3-4times & it's been great.

Yes i would start again when you can, it bed time here now , so i'll look into the spec's of your laptop,

Ok MKL is supported in the kernel so ignore that.
You may also consider resetting the BIOS, just to be on the safe side,incase a setting is incorrect.

i'd try reverting the kernel before starting again & if it doesn't work then consider a fresh start

It maybe easier to install "Mainline" this app helps change kernels.
here's a site with help on Mainline (At the bottom) & other methods.

I have been busy with work stuff, but I was getting ready to reinstall my system, taking in consideration @Ocka suggestion about the order of the two systems in my drive's partitions, I mean putting Windows at beginning of the drive, but just recently I turn on my laptop (in this week I only suspended, never turn off) and notice that boot was quite fast and this is the systemd-analyze output

Startup finished in 17.453s (firmware) + 9.513s (loader) + 4.281s (kernel) + 10.551s (userspace) = 41.800s reached after 10.505s in userspace

This is a time that I find reasonable.
The only thing I have done was run an update upgrade a couple of day back, I'm happy with this but I really don't know how it happen :sweat_smile:
I will continue checking the startup times for a few days and if everything is still fine I will mark this (update & upgrade) as a solution. Thank you very much for the help


Hey! If this helped, please Mark it as a Solution!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.