Boot up goes straight to internet

When I turn on the computer and boot up, Zorin goes to the desktop for about a second then connects straight to the internet. How can I stop it going straight to the internet ? Can this be done in the terminal ?

You can do so with GUI:
In Network Manager settings, uncheck the box for "Connect Automatically".
Or

sudo systemctl disable NetworkManager-wait-online NetworkManager-dispatcher NetworkManager

The terminal tells me that the command systemctl is not found.
How do I get into the GUI and find the Network Manager settings ?

That is odd.... Can you please post the output of:

sudo dpkg -l | grep systemd

When I type that in, I get:

245.4-4ubuntu3.15 amd64 system and service manager
ii systemd-sysv 245.4-4ubuntu3.15 amd64 system and service manager - SysV links
ii systemd-timesyncd 245.4-4ubuntu3.15 amd64 minimalistic service to synchronize local time with NTP servers

Are you on MX Linux? Which distro are you using?
You should be seeing a lot more than that one line.

Excuse my ignorance, but I'm not sure what that means. As far as I'm aware, I'm on Zorin OS 16.

How do I get into the GUI and find the Network Manager settings ?

This is a good question. I am using Zorin OS lite... not Core.
Opening the GUI gnome-control-center Zorin Settings, I do not see the usual NM settings in it.

Yeah, right you can do so with GUI.

How ?