Booting time slowed down after removing windows

Hi i removed windows 10 from dual boot by formating the windows partition and i used grub customizer to set the booting time to 0. but zorin takes long time to start, it wasn't like this.
anything i should do to speed the booting time?

CTR ALT T to enter terminal

systemd-analyze Please post the results

One of the things that you can do right away, is insure that SECURE BOOT is disabled in the BIOS too.

For cross reference, these are my results from a stable system.

Startup finished in 15.844s (firmware) + 504ms (loader) + 3.216s (kernel) + 7.115s (userspace) = 26.680s
graphical.target reached after 7.110s in userspace

Startreker

I do not recommend this. Should you need to enter Recovery Mode, this can make doing so very difficult.
A few seconds are worth paying to be able to access the Boot Recovery Mode.

As for your actual issue:
Please open a terminal and run blkid.
Note all UUID's.
Now, openthe /etc/fstab file and compare the entries against what you boted from blkid. Remove any UUID's that are in /etc/fstab that were not listed in blkid.
When finished, save the file. Then run:

sudo update-initramfs -u

1 Like

Startup finished in 3.034s (firmware) + 24.077s (loader) + 3.530s (kernel) + 9.367s (userspace) = 40.010s
graphical.target reached after 9.355s in userspace

Your total is about double mine. Do you know if you are running on a mechanical hard drive? If you are, that could explain the extra time its taking to boot, mechanicals are slow. If your getting that boot time with an SSD, thats not normal I'm afraid.

I think i have followed what you suggested but still take more time than it use to do. i am partially sighted, could you tell me what should i remove here are the value I foumd:
Terminal:

/dev/sda1: UUID="8A33-F918" TYPE="vfat" PARTLABEL="EFI

/etc/fstabSystem Partition" PARTUUID="0f4d654b-3bd8-4e4f-b979-673da47859d4"
/dev/sda2: UUID="d5e559a1-a4f4-470a-8292-c88ab91d485e" TYPE="ext4" PARTUUID="7ca358d2-19f8-413e-9e15-94dbbf30d7a8"

/etc/fstab:

etc/fstab: static file system information.
UUID=d5e559a1-a4f4-470a-8292-c88ab91d485e / ext4 errors=remount-ro 0 1

/boot/efi was on /dev/sda1 during installation

#UUID=8A33-F918 /boot/efi vfat umask=0077 0 1
/swapfile none swap sw 0 0
#UUID=8A33-F918 /boot/efi vfat defaults 0 1
UUID=8A33-F918 /boot/efi vfat defaults 0 1

I believe the easiest route would be to boot from LiveUSB (what you installed Zorin From) and run Boot Repair:

I tried boot repair but no joy , in the end a drstic decision required, i backup everything manually and i did a fresh install, well it was the right decision because it solved so many small errors.

2 Likes