Booting to memtest

Hey folks, hope this is an easy one. I have an old laptop that likely has some kind of hardware issue. I tried multiple different distros and Zorin is the only one that seems to be working so far. Now that the device is functional for the time being, I wanted to run a RAM test to see if that might have been what caused it to have so many problems on Windows/Alma/Mint/etc. However, I can't seem to get it to boot to the GRUB menu to select the memtest option. I tried editing /etc/default/grub and changing the timeout style option to menu instead of hidden, as well as changing the timeout time to 20 seconds. Both times running update-grub and restarting caused a white screen with an unrecoverable error message. It took several hard restarts before it would actually get back to the OS again. Is there a better way to accomplish what I'm trying to do?

PS. As a fun bonus, the OS no longer renders the capital letter S anywhere in the UI. Software is now just oftware, etc. Not sure what's up with that.

Both of those sound like Graphics card issues.
Can you use

sudo lshw -C video

to determine your graphics and drivers.
You might also post a screenshot of your grub file in case there is an error you missed. For example:


Instead of


Usually, tapping esc (EFI Boot) for reaching Grub Menu or holding down Left Shift Key for Legacy MBR boot will reveal the grub menu.

So, I think we've made positive progress. Yet another reboot and the grub menu appeared. Memtest wasn't there, so I have to figure out how to access it, but I'll take a small victory. Trying to boot back to the OS caused yet another white screen error, and I had to hard shut down two more times before it would let me log in. Also, the letter S is back, so that's great.

Your Nvidia card - what Driver are you using? You can check with Software & Updates > Additional Drivers tab.
Have you at any point used GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"?

You also might try:

sudo apt install memtest86+

Doing so will automatically add it to grub. If it is not added to grub, you can run

sudo chmod +x /etc/grub.d/20_memtest86+

sudo update-grub

Screenshot from 2023-11-18 10-59-05

Alright, so this is the driver info. It's using whichever one it came with during installation. I checked if memtest86+ was already installed and it was. I verified that the file existed in the grub directory as well. I ran the chmod command as well, then ran update-grub. Another reboot, another white error screen, another hard shut down, then it got to the grub screen. Still no memtest option, just Zorin, advanced options, and UEFI. I'll try that grub file edit and let you know how it goes.

So I tried making that edit and running update-grub. One thing I noticed, and maybe it'll help troubleshoot, but when I run update-grub, it explicitly says it's adding an entry for the UEFI settings and doesn't mention memtest at all.

So I ended up just creating a boot drive with memtest on it and used that. The test tapped out before the first pass of tests was even done because it hit 10k errors. I guess this explains why other distros constantly failed to install, so it's a small miracle it can even run Zorin.

Wow. Looks like you may have narrowed this down.

Can we assume you have checked, (cleaned connectors with isopropyl alcohol) and re-seated your memory card/s graphics card before consigning them to garbage?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.