Booting up

I've just installed Zorin OS 16. When I boot up, I'm taken to a page that says "Windows has failed" or something like that. I then press "Esc", then F12 which then takes me to that booting page. I can then access Zorin and boot up.
However, that's a pain in the patootie !
Without having to go through the whole reinstall process again, what can I do to ensure that Zorin just boots once I've turned the computer on ? It did so when I first installed {I had to reinstall because my panel disappeared !}. I'm not at all technical so please, advise me the way you'd advise a 9 year old child that has never switched on a computer, because I've found that most of the computer talk is another language to me.
Thanks !!

1 Like

Are you dual booting with Windows?

1 Like

No. When I bought the computer, Windows 7 had once been on it and I've never been able to get rid of any reference to Windows 7. I'd love to be able to, but no one has ever been able to show me how.

1 Like

That would be the file in the bootloader. You can replace the bootloader by creating a new EFI partition and removing the old one. You would need to reinstall any operating system.
This above is a tip, not a guide.

Is there no way I can do it in the terminal ? Can the terminal not fix it that when I turn the computer on, I just go straight to the Zorin desktop ?

Have you completely overwitten Windows? If you have, then you certainly can do it in terminal.

sudo efibootmgr

Identify the Windows Boot Manager. It may look like Boot0001... Let's say as an example it is Boot0001:

sudo efibootmgr -b 0001 -B

You probably do not need to, But I would run update grub...

sudo update-grub

before rebooting to test it.

If you have not overwritten Windows, doing away with it entirely, then I do not recommend the above, instead, you should use the partition manager to delete the Windows partition, expand Zorin OS into it and recreate your EFI Partition, instead. If it was me, I would just Reinstall Zorin OS to make a clean break of it.

As an aside, Windows is completely overwritten.
But my question about the terminal was regarding the boot up not going to the BIOS page. Is there any way I can jig about in the terminal so that when I turn the computer on, I go straight to the Zorin desktop. I don't want to have to re~install if I can avoid it !

Did you run the commands I posted above?

Just edited post #7 to tidy up the quotes.

Interestingly, Windows doesn't show up.

I am sorry, I am not following you. I thought Windows was not showing up before, as you had overwritten it? Has something changed, but not changed in the way you want? Can you describe what has happened and what your goal is?

I was going to reply to your questions, but a strange thing {well, strange for me !} happened. I went into the boot page, mainly to copy what it says so I could show you what was written there. Anyway, once on the boot up page, I noticed that there are options to change the way the computer boots up so I made a change there and the problem I first posted about has gone !
Thanks for your help though, it gave me things to think about.

1 Like

A lot of the time, it is not about providing answers, but helping others to find them.
And when I do provide an answer, it is usually because I bumbled across it.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.