Bootloop since last update

Hello everyone,

Since last update, Zorin OS won't boot anymore.

Here is a screenshot just before the system restarts itself (sorry for the bad quality):

I don't know if the problem is with the integrity or with the link training.

I run Zorin OS on a Mac Mini 2018 with reFind.

I have try to run a file system check. No error.

This topic may help you:
You would need to edit grub at the Grub menu.

I have already seen this topic. But I don't have grub. I use reFind.

I have never used rEFInd, sorry that I was unaware; I though rEFInd assists grub, rather than replacing it.

Maybe you're right, but when I try to update grub with a live CD, I have an error that say grub is not found.

Maybe I am wrong, too. :wink: Although I have recommended rEFInd many times, I have never actually used it.
You can tell by my immediate need to look this issue up...

I am aware of the "AE_already exists" error on standard PC's, but any resolution seeking I would advise would all begin at Grub. The other method would be running fsck given the "couldn't get size" error.

I do not want to give you faulty information...
There are several Mac Users on the forum running Linux, so hopes are high they may know something. In the meantime, I will also keep searching the web.


You were right. reFind replace grub for the first part of the boot. But grub gets the hand back for the rest.

update-grub could not find grub because I need to mount /sys /proc and /dev too.

After that, I have followed your link to add loglevel=3 to my grub file.
Unfortunately, now the system reboot right after reFind load grubx64.efi.
I have tried to remove quiet and splash but same thing.

I will try to add noapic noacpi nosplash instead of quiet splash.

Now, I get this few seconds before reboot:

I see nothing wrong here :disappointed:

At any point, do you see the Zorin Grub menu?

No. I never see a grub menu working with reFind.

When I was using Hackintosh, I used Clover bootloader.
My understanding is that, Clover, rEfind and grub2 are all independent bootloaders.

This is about the only information I could find regarding rEFind and boot loop:

Compared with Grub, there is way less information for this boot loader.

1 Like

This part looks helpful, at least:

If you can boot into your Ubuntu installation or an Ubuntu emergency disk, you could run the Boot Repair utility and select the "Create BootInfo Summary" option. (DO NOT click "Recommended Repair," at least not yet!) When asked whether to upload the report, click "Yes," and then post the URL provided here. This should provide helpful diagnostic information on your configuration

1 Like

When I try sudo efibootmgr -v I got the following error: EFI variables are not supported on this system.

@Aravisian unfortunately I can't boot on the system. But from the live CD when I try to create a BootInfo Summary, the pastbin link is not complete

Very weird.

But I have understood that the efi partition is not mounted in /boot but in /boot/efi. Maybe I can try again update-grub.

I think the problem is not with reFind. In the last log I've posted, we can see that the system start to boot.

I have try a boot repair anyway. And after that I got an complete pastbin URL.
And a little message that say Locked-NVram detected

But after that, my system boot again :partying_face:

I have restored quiet splash in grub because the system won't halt or reboot.

I have two new problems now:

  • One of my three screen is locked to a low-resolution setting
  • The windows size and position are no longer saved

Thanks for your help :slight_smile:


Glad to here at least you can boot now :slight_smile:
Please create a new thread for those display problems.

1 Like

I will search before posting :wink:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.