Brightness controls don't work properly after unlocking screen

It’s kinda hard to describe, so I’ve attached this GIF to show what I mean. I’m using a Lenovo IdeaPad 3 ( running the Core edition.

Can you try the suggestions here?


The brightness control keys do work, but just pressing the Brightness down key sets the brightness to 0% whereas the Brightness up key works normally. The issue described in that forum post describes an issue where the brightness keys do not change the brightness at all.

EDIT: I just tried it and got this error:

Sorry, from your gif it seemed to me that the keys aren’t working.
Also, I forgot to ask - does Menu -> Settings -> Power -> Screen brightness slider work for you?

How about just xrandr --set BACKLIGHT_CONTROL legacy ?

Yes, the sliders in the user menu and the Settings app both work flawlessly.

Just tried that now, and now I’m getting a new error:

Please give the output of xrandr --listmonitors

Try xrandr --output eDP --set BACKLIGHT_CONTROL legacy

This is all I get:

Replace BACKLIGHT_CONTROL with intel_backlight and retry. If still nothing then try these:

Would that work considering both my CPU and GPU are made by AMD?

Probably not. May want to try the link instead.

I tried that also, still no luck. I also checked the forum post you linked, but I’m not sure which commands to use and since I last tried, xbacklight doesn’t seem to work properly.

Try this one first (note that while booting, hold shift to get into the recovery menu, then press ‘e’ - if shift doesn’t work, try tapping esc key repeatedly):
1. Passing acpi_backlight=vendor to the kernel at boot
To try this temporarily, on boot at the grub screen, with the Mint option highlighted, press ‘e’ on your keyboard. If the Grub boot menu does not normally show up on boot, press and hold the ‘shift’ key whilst booting until it shows. On this screen, navigate to just before it says ‘quiet splash’ and type
Code: Select all


then press ctrl-x to boot it.

Test your Fn keys once the system boots and post here.

That’s for Mint… Are the keyboard shortcuts the same?

For the grub menu they are.

I just tried it now, here’s the results:
The backlight is now set to 100%
Both the function keys and sliders are unresponsive and do not change the brightness
Pressing brightness down makes the screen flash black for a split second and then back to full brightness

A reboot will get rid of the grub change.

The only other option seems to be to install xbacklight - I recommend Synaptic but the terminal is fine too.

Yeah, I tried that; but alas it didn’t work. At this point, it seems like a lost cause and a minor annoyance I can live with. Anyways, thank you so much for your help.