Brightness controls not working OLED Z16

But I do have problems with zorin lite 16 and Asus zenbook OLED

While the display shows fair brightness neither Fn-Keys are functional (overlay shows up) nor any brightness slider in settings shows any effect.

Anyone can point out a solution for this?
So far digging on google showed no results.

Hi RaZi and welcome to the forum. You might try to open the terminal and copy and past this.

gedit /etc/default/grub

Change the grub cmdline to this;
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor acpi_osi=linux"

sudo update-grub

Restart and check if it worked, if not use the commands from below :grinning:

sudo add-apt-repository ppa:apandada1/brightness-controller
sudo apt update
sudo apt install brightness-controller

Hi Michel,
no dualboot, since no grub (according to my understanding)
So I went for brightness-controller and success...
Many thx for this!!!

Most welcome! mark my post as solution please since it fixed it :slight_smile:

seen such markings but cannot identify a way to do this? Flag as something else and comment as solution?

I have marked #2 the Solution on behalf of the OP.


Let me summarize this:

  • Model is ASUS ZenBook 13 OLED UX325EA
  • OS Zorin 16 Lite
  • The proposed solution via Grub showed no effect (I tried it meanwhile)
  • Using the brightness-control app, it is possible to control the brightness for the built-in and a second display
  • The brightness control via the keyboard (FN-F4/F5 keys) was not achieved
    The solution is a workaraound.
    For me it is sufficient since I don't tinker a lot with brightness.
1 Like

@RaZi FYI. To mark a post as the Solution, click on the "..." icon under the post.
There you will see the :ballot_box_with_check: Solution marker.
Click on that.

@zabadabadoo When I asked for It I definitely could not see the "solution" marker in the elipsis menue. Now I see it prominemtly placed on every post. Guess it was because just having joined the forum hours before and thus not beeing granted rights to mark posts as solution?

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.