Brightness controls stop after sleep


Laptop model: Lenovo Legion 7 (2021)
ZorinOS Version: 16
CPU: AMD Ryzen 9
GPU: GeForce 3060

First time ZorinOS user here. I just downloaded the latest version and I'm really loving it. The only problem is that my brightness controls stop working after I resume my laptop from sleep. The controls work fine after a fresh boot. I've actually had this issue with other distros, but I'm determined to make it work with Zorin because it's been my favorite so far.

I've looked online and I haven't been able to find a solution that works. It seems like it might be an issue with the Nvidia drivers, but I figured I would try to see if anyone has a solution here.

Things I've tried adding to the grub cmdline:

  • amdgpu.backlight=0
  • video.use_native_backlight=1
  • acpi_backlight=vendor acpi_osi=linux
  • acpi_backlight=video acpi_osi=linux
  • Switch to discrete graphics and add nvidia.NVreg_RegistryDwords=EnableBrightnessControl=1
  • Various combinations of any of the above

I've also tried updating to Nvidia 495 drivers, but nothing seems to make the brightness controls work after resuming from sleep. The brightness goes to 100% which is pretty painful so I'd love to find a solution.

Thank you for any help you can provide!

1 Like

In gnome-control-center (Settings in the App Menu), moving to the Power Manager tab, do you see an option for Handle display brightness keys?

(This is probably one of my dumber questions, but is worth a shot...
Also: Just found this thread:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.