Brightness keys NOT WORKING!

I am using Zorin OS 15.3 Core version (x64) on my Acer Aspire 4736 with Intel Graphics. Since the install, the brightness keys on my laptop are not working. I followed tutorials on youtube, but still couldn’t solve the issue. The brightness controller app just places a black screen as an overlay and changes the opacity which is not what I want. Earlier in Zorin OS lite edition, I faced the same issue but was solved with a youtube tutorial. It seems there is some issue with Zorin OS Core. I don’t want commands that just display a black overlay screen, but instead want the brightness keys to work and reduce the actual brightness of the screen. PLS HELP
The tutorials I saw showed the process of saving a script in a text document and then renaming the text doc. as “20-intel.conf” and then saving it in the X11 folder.

@arnavpadwal Hi and welcome to the forum.
Does the Brightness slider tool in the in the panel adjust your screen brightness OK, or is it just your hardware keys. On my laptop (Not Acer Aspire) you have to press [Fn]+F6 and [Fn]+F7 to adjust brightness.
I don’t have an Acer Aspire to try those hardware brightness keys myself, but I am sure others on here do. @Aravisian maybe.

Note there is also a “screen brightness” slider in Zorin>Settings>Power

I have to press the keys : Fn + right arrow (increase)
Fn + left arrow (decrease)
Even the slider in the panel does nothing.
I have tried this:
Screenshot from 2021-02-01 17-36-09|690x387

but got this error:

Pls help. Thank you in advance.

I have an Acer Aspire, but it does not have Brightness controls.
The Panasonic has them- but that is a Whole 'Nother Aminal.

The script you mentioned is this:

Section “Device”
Identifier “card0”
Driver “intel”
Option “Backlight” “intel_backlight”
BusID “PCI:0:2:0”
EndSection

And it is placed in location:
/usr/share/X11/xorg.conf.d/20-intel.conf

You can run this in terminal, then paste in the above section, then exit and save.

sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf

Alternatively, you could

sudo nano /etc/default/grub

And add the following to the line for Linux Default:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash video.use_native_backlight=1”

Then

sudo update-grub

OR

sudo nano /etc/default/grub

And make the following line for Linux Default blank:

GRUB_CMDLINE_LINUX_DEFAULT=""

Google Photos

I have made the change but not saved it. Pls check whether it is correct. I am a linux noob and I am afraid if I do something wrong and my laptop crashes, as this is my main laptop and very important for me right now. Thanks for your timely support😊.

While you are in there… You Might consider changing grub timeout to 5

GRUB_TIMEOUT=5

Everything else looks good.
The reason behind the time out (This will increase your boot time by about ten seconds) is to ensure you can access the Recovery Menu easily if you need to.
If you are freshly migrating to Linux, you may need to access that recovery menu before long and it would be better to have it easily accessible.

What the Timeout does at zero or at five seconds:
When you begin the boot up, a Loading Menu will run. If your timeout is set to 0 seconds, you probably won’t even see it. If you set it to five seconds, then it will wait that amount of time before vanishing, for you to make a selection on that menu. You can set it to 7 seconds or ten seconds just as easily…
Some sloths I know set it to 60 seconds. But then, they also keep their monitors hanging upside down, too.
It is during that time that you can also select Recovery Mode or Recovery Menu and having it set to zero can mean you have to be Super Fast with your finger on the Left Shift Key to grab it.

1 Like

I made those changes, but still the keys are not working. Now when I press the brightness keys, my keyboard stops responding for 5-10 seconds, which did not happen earlier.

In that case, the system did not like the change. Let’s revert those back to the way it was before.
Have you tried the “sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf” script, yet?