Brightness keys on HP Probook 450 G6 not working

If I press either Fn+F3 or Fn+F4 (which are supposed to be brightness down and up), it instead activates/deactivates the internal microphone (the same as Fn+F8 does which is what it is supposed to do).

I read somewhere that it might have to do with 2 different keyboard drivers overriding the assigned keycodes. But I couldn't find anything about keyboard drivers in ~/.local/share/xorg

Also, the keycodes for both Fn+F3 and Fn+F4 are the same:
keycode 190 press | keycode 190 release

What options do I have to troubleshoot this? On Windows the keys work as expected, so I guess it is not a BIOS problem?

I think you are not the only one having this problem:

1 Like

Hi, you can use your terminal for controlling brightness.

You could install xbacklight package
sudo apt-get install xbacklight
and then if you want to increase the brightness level, type
xbacklight -inc <level in a range of 10 - 100> and vice versa:
xbacklight -dec <level in a range of 10 - 100>

or you can check this for troubleshooting :


@marko94 Thanks for the suggestions, Marko. I chose to try Method #2 in the article you cited. Method #2 provides code to install app called Brightness Controller. Not sure if I will stay with it because it seems override the Night Light setting if you turn on Brightness Controller. Brightness Controller probably gives you more control than Night Light but while I'm in the "how does this thing work" stage, the more control can be tricky in trying to find just the right combination.

In any event I was able to turn down the brightness. Thank you, my eyes were frying. And in the long term, I may find that perfect combination and stay with Brightness Controller.


hi, if you think your problem is solved, please tick :ballot_box_with_check: to mark a thread as solved. This will help the future visitors to this forum to find a solution they are looking for.
I just noticed that we did not get any reply from the OP yet :stuck_out_tongue:

We got the intruder :slight_smile: again , hehe

1 Like

I really should make it a habit to ask people to create their own thread. But even we put a big sign saying:
No Hijack Allowed!

people will ignore it :wink:

I think it is ok until same issue is in one thread :smiley: or maybe not..hehe

I hope OP will come back here to find the solution you have offered.
Another forum rule:
"Do Not Abandon Your question"
But I am sure this one also will be get ignored... Oh well.

I think I asked about this in another thread where I had multiple questions going on. I could post this reply and solution check mark over there but given it has multiple issues in it, that might be just confusing over there as well. I am learning forum etiquette as well as Linux I am afraid. I will try to keep to single topics from here on out.

Also, did my venturing into this thread violate any kind of norm? I see the intruder comment and wonder if that is me. Just let me know if I need to be aware of any other forum guidleines. I am sort of like a kid in a candy shop trying to read everything and learn what I can along the way.

EDIT: I just re-read everything above in the thread again. I think the intruder had to be me. Sorry!

Six months - hard labor.



Welcome to the candy shop!

No, really there is no need for apologies.
The rule is quite relaxed here :slight_smile:

For anyone who is polite and friendly, all volunteers are more than happy to give an advice.

1 Like

@FrenchPress Thanks, that is exactly my problem, too. Unfortunately, HP didn't seem to bother. I still don't know how to fix it...

Does anyone know of a way to adjust the keyboard layout to rearrange the keycodes?

@marko94 Thanks for the suggestion! Do you think I could somehow bind the keys to these commands? Then this might actually be a workaround. Although I still think it won't be possible to use Fn+F3 and Fn+F4, because the problem is that they are bound to the same keycode as Fn+F8.


In my case I didn't find a solution to bind the keys to those command.

I tried, but no luck. Only working solution was manually adjusting it in terminal.

Just for the reference,I am talking about WM (Bspwm) not a Zorin, but had a same case like you :slight_smile:

OK, well, I can adjust the brightness with the slider. It's just the key binding that I would like to be able to change. It doesn't look very promising though, because I think it is due to a BIOS issue from HP and their recent update was supposed to fix it, but it didn't.

Did you tried to update your bios ?

I didn't have the time to do that yet. But in the HP thread someone with the exact same laptop model wasn't able to fix it via the BIOS update. I will try it, eventually. Just need to free up some time aside work and family :slight_smile:

Sure. Try and see. If you need more help, we are here :slight_smile:

Maybe in the meantime, someone find a fix xD

Thanks for motivating me. I did it straight away and it didn't help. Still the same issue, even though the update is pretty recent (May 31, 2021). :frowning:

1 Like