Brightness on old laptop

Hi to all,

I have installed Zorin on my old Sony Vaio, all works except for the brightness.
Both Fn key and the tray bar seems to work properly, but the brightness doesn't change.
Reading on others topic I have partially solved:

1 xrandr --listmonitors
Monitors: 1 0: +*LVDS-1 1366/344x768/194+0+0 LVDS-1

2 xrandr --output LVDS-1 --brightness XX where XX is from 0.1 to 1

How could make this without the terminal?

I've tried
xrandr --output LVDS-1 --set BACKLIGHT_CONTROL legacy
and
xrandr --output LVDS-1 --set intel_backlight legacy
but nothing changed.

I'm using nouveau driver.

Here inxi-faz

System:
  Kernel: 5.15.0-46-generic x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.15.0-46-generic 
  root=UUID=b5a0b39c-9614-42ec-bce8-516fd04301f8 ro quiet splash 
  vt.handoff=7 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Zorin OS 16.1 base: Ubuntu 20.04 LTS Focal 
Machine:
  Type: Laptop System: Sony product: VPCEH2J1E v: C1064KBR serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Sony model: VAIO serial: <filter> BIOS: INSYDE v: R0180Z9 
  date: 04/28/2011 
Battery:
  ID-1: BAT0 charge: 22.2 Wh condition: 22.2/45.0 Wh (49%) volts: 3.9/10.8 
  model: SONY Corp. VGP-BPS26 type: Li-ion serial: <filter> status: Full 
CPU:
  Topology: Dual Core model: Intel Core i5-2450M bits: 64 type: MT MCP 
  arch: Sandy Bridge family: 6 model-id: 2A (42) stepping: 7 microcode: 2F 
  L2 cache: 3072 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19955 
  Speed: 798 MHz min/max: 800/3100 MHz Core speeds (MHz): 1: 798 2: 938 
  3: 798 4: 798 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: mmio_stale_data status: Not affected 
  Type: retbleed status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW, 
  STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: NVIDIA GF119M [GeForce 410M] vendor: Sony driver: nouveau 
  v: kernel bus ID: 01:00.0 chip ID: 10de:1055 
  Display: x11 server: X.Org 1.20.13 driver: modesetting 
  unloaded: fbdev,vesa resolution: 1366x768~60Hz 
  OpenGL: renderer: NVD9 v: 4.3 Mesa 21.2.6 direct render: Yes 
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
  vendor: Sony driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:1c20 
  Device-2: NVIDIA GF119 HDMI Audio vendor: Sony driver: snd_hda_intel 
  v: kernel bus ID: 01:00.1 chip ID: 10de:0e08 
  Sound Server: ALSA v: k5.15.0-46-generic 
Network:
  Device-1: Qualcomm Atheros AR9285 Wireless Network Adapter vendor: Foxconn 
  driver: ath9k v: kernel port: 4000 bus ID: 07:00.0 chip ID: 168c:002b 
  IF: wlp7s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Sony driver: r8169 v: kernel port: 2000 bus ID: 13:00.0 
  chip ID: 10ec:8168 
  IF: enp19s0 state: down mac: <filter> 
  Device-3: Qualcomm Atheros AR3011 Bluetooth type: USB driver: btusb 
  bus ID: 1-1.5:5 chip ID: 0cf3:3005 
Drives:
  Local Storage: total: 232.89 GiB used: 24.65 GiB (10.6%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Crucial model: CT250MX200SSD1 size: 232.89 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: MU02 scheme: MBR 
Partition:
  ID-1: / raw size: 232.38 GiB size: 227.68 GiB (97.97%) 
  used: 24.65 GiB (10.8%) fs: ext4 dev: /dev/sda5 
Sensors:
  System Temperatures: cpu: 49.0 C mobo: N/A gpu: nouveau temp: 52 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 209 Uptime: 2d 10h 43m Memory: 3.81 GiB used: 2.33 GiB (61.2%) 
  Init: systemd v: 245 runlevel: 5 Compilers: gcc: N/A Shell: bash v: 5.0.17 
  running in: xfce4-terminal inxi: 3.0.38 

Thank you in advance

Check Out these,

4 Likes

Hi,
after breaking X a few times (I owe a Tony George a beer for Timeshift), i found the solution, here for who has the same issue:

sudo gedit /etc/default/grub

change the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

then

sudo update-grub

and reboot.

The only issue is that now brightness could reach 0% (completely black screen), hope to remind this :sweat_smile:

Thanks to @ghostminator