Brightness problem on Legion 5 Pro

Hi, I'm currently new to Linux and so far everything has been running alright in Zorin OS, aside from me unable to control the screen brightness on my Legion 5 Pro in discrete mode (the brightness is maxed out). So far, I've tried adding GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nvidia.NVreg_RegistryDwords=EnableBrightnessControl=1" to the grub file but it doesn't solve it. Any help will be appreciated.

My laptop specs are Legion 5 Pro 16AHCH with Ryzen 5 5800H and RTX 3060 using the nvidia-driver-515.

I use brightness controller (also on RTX 3060 with 515 driver), partly due to it being desktop independent:

sudo add-apt-repository ppa:apandada1/brightness-controller

sudo apt update && sudo apt install brightness-controller

1 Like

Thank you never knew that existed ..... it works .... :+1:

Thanks for the solution, I just recently tried using the app and it works flawlessly, although the keyboard shortcut for brightness still doesn't work. :+1:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.