Broadcom 43142 wireless adapter doesn't work

Before posting, I did research and try several different options to get it to work. It still doesn't work, so I'm hoping someone has another solution to try.

The problem
This is a 6-year-old Toshiba Satellite C55-C5241. Everything seems to work but Wifi after installing Core 16. Ethernet works. The wireless card is Broadcom BCM43142 802.2 11b/g/n.

Once Zorin was installed, the Additional Drivers window showed it was using Broadcom 802.11 Linux STA driver that came with bcmwl-kernel-source.

This wasn't working. The wifi window says there is no adapter.

What I've tried

  1. Update Zorin. There was an update available, I updated. Did not help.
  2. Update and upgrade packages (apt-get update and upgrade). Did not help.
  3. I tried uninstalling bcmwl-kernel-source and installing broadcom-sta-source, broadcom-sta-dkms and broadcom-sta-common. Did not help. (source)
  4. I tried uninstalling bcmwl-kernel-source and installing firmware-b43-installer. Did not help. (source)

When I tried step 3 and 4, the Additional Driver window said the device wasn't working. It only said it was working with bcmwl-kernel-source driver, but Zorin did not detect the adapter. So even though it said it was working, the Wifi window said there was no adapter. Reboot included.

Note, I did reboot after each attempt to fix this problem.

I do have secure boot enabled. I'm not sure if disabling it would help, yet.

Anyone got any other tips or solutions?

Hi and welcome to the forum :slight_smile:
If you have not tried yet, I recommend you to disable secure-boot and see if it helps.

I've never enabled secure boot on any of my laptops and desktops and I've never had any issue. Linux does not need secure-boot.

Thanks. Can you confirm, is this the correct way to disable it? I haven't seen anything else.

Welcome to the forum! Don't know if this will help...

How to Fix no Wireless Network Issue in Ubuntu Linux It's Foss

1 Like

You can do that in BIOS.
No command line required (TM)

1 Like

There has been many issues with this card. Have you tried this?

The solution may work for you.

2 Likes

Not for a faint hearted....

  1. I tried installing bcmwl-kernel-source on a live run of Ubuntu 14.04 (with my LAN cable) and checked if WLan works now. (And yeah, it did confirm that Ubuntu 14.04 / BCM43142 / bcmwl-kernel-source were not the problem.)
  2. I went to /etc/modprobe.d and cross checked the files there with my hard disk installation's version of the same folder.
  3. This /etc/modprobe.d directory contains configuration files which contain blacklisting information for different modules. I made a note of the available files and later removed what was not available here from my hard disk installation's version of the same folder too.
  4. I went to /lib/modules/3.*/updates/. This is the directory that stores all your modules (wl, b43, etc. ... ) and the one that I messed up with various custom patched versions of wl modules listed in various forums.
  5. After cross checking with my hard disk installation's version of lib/modules/3.*/updates/, I manually removed all Bluetooth / wireless / dkms / wl / (and in particular one mac80211) and cleaned up any other modules that are related to wlan.
  6. I finally replaced (did a recursive copy onto) the /etc/modprobe.d and /lib/modules/3.*/updates/ directories (of my hard disk installation) with the same directories from the live OS.
  7. Reboot
  8. Do sudo apt-get install bcmwl-kernel-source. This is the official working driver for BCM43142 for Ubuntu 14.04.
  9. Reboot and sudo modprobe wl and viola, wireless was working!

Or this:

1 Like

Yeah....like @337harvey mentioned there are many issues with this card and I think the suggestion would be the best bet at reception in the long run you suggest.

1 Like

It recommends removing the tried versions of the driver (purge and manual search/ remove of anything left. Then install from the repo or one of the updated drivers). Every driver you try should be removed prior to trying another. Otherwise the system will get confused, if you don't.

3 Likes

It appears secure boot was the culprit. One of the reasons I didn't disable it initially, I couldn't easily get to BIOS on this Toshiba laptop. I've had it for 5 years, and every time I needed to get to BIOS I had to use Windows' advanced startup settings. The F2 and all other methods never worked.

I accidentally stumbled on another way to get to BIOS. While I was booting Zorin from my thumb drive, F12 allowed me to get to the boot menu screen. This screen has an option to "Enter Setup", which is BIOS. Hopefully, this will help someone.

Going back to the WiFi issue.

When I disabled secure boot, I had firmware-b43-installer installed. All other drivers were purged. Wifi worked.

So I tested a few scenarios:

  1. I uninstalled firmware-b43-installer, which meant that all drivers at this point were uninstalled. The wifi worked. So whatever wifi drivers Zorin uses, they worked. I actually don't think firmware-b43-installer driver was used at all. I think whatever Zorin uses internally for wifi adapters was used. Uninstalling it didn't change anything.

  2. When Zorin was installed, it installed bcmwl-kernel-source driver. So I installed this driver, to see if it works now since it was the default. Wifi worked. This time it does say under Additional Drivers that this driver is being used.

So it appears that all the trouble I had was stemming from the secure boot. Based on my testing, the Broadcom 43142 adapter works with the default third-party driver bcmwl-kernel-source and it works without it, with the default drivers that Zorin ships with.

The installation wizard wording suggests that a secure boot is necessary. One of the reasons I enabled it since I had it enabled on Windows. There should be a warning that enabling secure boot will break OS functionality. That recommended setting is to keep it disabled.

Hopefully, this will help anyone else having trouble with the wifi adapters.

2 Likes

Thank you for following up and letting the Forum know the outcome! All this will help the mods when they address issues in the future and those like myself.

Glad it was resolved and you may now gain experience with Zorin. And that is great! :+1:

Secure boot has been a thorn in the side of many and is as you can see in other posts one of the questions asked a lot.

Again Thanks and enjoy Zorin. Look forward to your post in the future and ways to improve a GREAT OS.

2 Likes