Broken Ethernet Networking for LAN Devices

I need some help, if possible, please.

My desktop here is unable to connect to certain devices on my LAN. One is an ASustor NAS and the other is a Synology NAS. They worked yesterday. I think they worked this morning but they don't work now.

My laptop running Zorin can connect to them. I have installed latest update on both but only the desktop has an issue. The laptop uses wifi and the desktop connects via ethernet. If I turn on wifi on the desktop - I have just noticed I can connect to them.

So something is wrong with the ethernet, can anyone suggest what to try next?

Coincidentally I factory reset my router today and changed my LAN IP addressing scheme and all the wifi settings. I thought I had done something wrong there but it looks like its all fine and it was the update that broke it.

EDIT:
I cannot browse to them using SMB/CIFS or connect to their web interfaces, I can ping them okay. Internet browsing also works fine otherwise. Transmission Remote GUI is unable to connect too, that isn't fixed on wifi.

Don't know if this helps or hinders:

I use gigolo to handle mounting the SMB shares on my LAN and then I use Nemo as my file manager. I have other networked drives that I can connect to so I don't even understand whats going on.

Seeing as its only ethernet where they fail to connect I thought there might be some misconfiguration when I changed the settings. This same PC when I boot into Windows 11 has no issues with the new LAN settings. Everything works. So i'm kind of at a loss as to what to do.

If I wasn't using gigolo then that link might help @swarfendor437 but I used gigolo bacause I couldn't get fstab mounts to work properly in the past.

Okay. So now I'm really confused as it's started working again.

So I'd been rebooting many times today by just going into the first option.
So I tried the advanced option.

So I tried the first one and it was still broken.

Then I tried again on the 3rd option and it was all working. Then I tried the first option again and now it was working. Then I've went through the normal Zorin on the first page of grub and now its somehow working again. I didn't do anything other then reboot.
Can anyone explain to me what happened or why it's now fixed seemingly like magic!

EDIT:
Still getting browsing issues with web interfaces but that's probably a separate issue.

UPDATE:
The browsing issue is all fixed. Reverted to windows for now. All working again there. I think. This second issue was related to the different bindings setup for the old network addresses once I changed them to the new IP range the other bits started to work again. Its late here I'll try Zorin again tomorrow.

Both OS's have been trying to maintain a claim on the ethernet adapter. Multiple restarts of Zorin have made it restart the adapter, like reloading the driver, and kept the configuration.

I figured this out when I noticed (i dual boot win10) that windows wouldn't connect to the internet unless I disabled/re-enabled the adapter, right after I had done the same in Zorin. So it wasn't the pipewire update, but something in either or both the Linux kernel and windows.

I find I have to do this sometimes in Linux (when I reload the adapter in windows) or vice versa. It's always random when this could occur. I haven't dove further into it yet because i have a project due this week and I'm scrambling to finish.