Broken update mirror

System wont update because it cannot fetch the ZorinOS upgrade repo. How can I fix this? (I've already tried to update and --fix-missing)

$ sudo apt upgrade -y
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  libfprint-2-2
The following packages will be upgraded:
  aptdaemon aptdaemon-data bind9-dnsutils bind9-host bind9-libs bluez
  bluez-cups bluez-obexd gir1.2-gdkpixbuf-2.0 language-selector-common
  language-selector-gnome libarchive13 libbluetooth3 libgdk-pixbuf-2.0-0
  libgdk-pixbuf2.0-bin libgdk-pixbuf2.0-common libgif7 libmutter-10-0 libvpx7
  linux-generic-hwe-20.04 linux-libc-dev nala openjdk-11-jdk
  openjdk-11-jdk-headless openjdk-11-jre openjdk-11-jre-headless
  python3-aptdaemon python3-aptdaemon.gtk3widgets vim-common vim-tiny xxd
  zorin-os-default-settings zorin-os-overlay zorin-os-printer-test-page
  zorin-os-upgrader
35 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Need to get 471 kB/126 MB of archives.
After this operation, 907 kB of additional disk space will be used.
Err:1 http://ppa.launchpad.net/zorinos/stable/ubuntu jammy/main amd64 zorin-os-upgrader amd64 1.2.18
  404  Not Found [IP: 185.125.190.80 80]
E: Failed to fetch http://ppa.launchpad.net/zorinos/stable/ubuntu/pool/main/z/zorin-os-upgrader/zorin-os-upgrader_1.2.18_amd64.deb  404  Not Found [IP: 185.125.190.80 80]
E: Unable to fetch some archives, try running apt-get update or apt-get --fix-missing.

Try changing to main server, not a mirror. (Updater -> Setting)

1 Like

Full procedure to get to settings is to start the Software Updater, click on Stop then click on Settings. On the interface that appears click on first tab, then against Software sources, use drop-down arrow at side of named mirror and change this to 'Main Server'.

1 Like

Just remembered, I think I have covered this issue as one of the first things to do post-install in both the Unofficial Manual for Zorin 15 and 17!

It still breaks


I refreshed the source list and ran sudo apt update but it still fails to upgrade

Try install the offending package manually from:
http://ppa.launchpad.net/zorinos/stable/ubuntu/pool/main/z/zorin-os-upgrader/

2 Likes

that fixed it, thanks