Brother MFC-J480DW - setup disappears in the middle of installing

strong text Everything has been working fine with my Brother MFC-J480DW installed on Windows 10 64-bit OS. All of a sudden Brother Utilities would not fully load so I could not scan receipts into my computer. I tried system restore. Re-starting, all the usual troubleshooting suggestions. I have installed and reinstalled the drivers and software many times. I decided to use the uninstall tool and start fresh. I went to the Brother website and downloaded the complete driver and software package. I was able to install the drivers and connect to my WiFi with no problem. it would not go further than that in setup. It stopped and disappeared before the software was installed. I tried using the original installation CD and I tried installing using the USB cable. Each time everything went fine until it was time to install the software. I do not know how to use this printer's scan features without the Brothers Utility Control Center 4. I have wracked my brain trying to figure this out. Does anyone have any knowledge re this particular problem? I would appreciate ANY and all advice and suggestions. Any insight would be great. I rely on my scanning to upload documents to my computer almost every day. Many times a day. I now am at a standstill. Please help! Thanks!

Since you purged everything, have you run

sudo apt install sane sane-utils libsane-extras xsane

Have you looked at the official troubleshooting guide?:



If you click on print option, the contents are shown in a new web page.

If it is too much of a headache, I would give vuescan a trial run (there is a demo version). I paid for the professional version as it has a decent interface that most proprietary companies do not offer and is more versatile than the 'de facto' "Document Scanner" application present on most distributions these days.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.