Browser don't work

Hi,

I'm on Zorin 16.3 core on X11. And there are strange things. I need multiple browser, for my two work and for my personal use. And I install Brave and Opera, they dont work. For Vivaldi, it's the same... Fire fox and Waterfox work perfectly... I don't understand. I try to install with .deb, with the termial, with flatpak. It's still the same. Brave dont appear and make some visual bugs, Opera are stuck and Vivaldi don't launch... If someone have any ideas It take :wink:

Thank

Have you tried switching to Wayland to see if it makes any difference? At least to rule out the display server, in case Google has made it a requirement for some reason.

Hi cannot succed to install Wayland. Do you have the command ? I try to Gnome and Mate, and it's not working. Just to see, I try with a usb key on the same os
but live to install brave and it's working...

i don't have a solution,all i can say is i'm using brave ,had opera and vivaldi before ,and they all worked perfect.
installed all through terminal .

I think even on Zorin OS 16 Wayland is installed, just not the default. Log out of your account, and on the login screen you should have a wheel icon to switch between Xorg and Wayland.

You may also try to disable hardware acceleration from within each browser's settings.

Hi,

On the wheel I dont have Wayland unfortunatly.

I cannot go in the browser settings, the browser don't open.

i don't have wayland either.
if u open a terminal and just type browser name ,like Vivaldi, and enter , it should open.(if installed properly)
or maybe try upgrading to 17.xxx

Correct. Z16 default is X11. Z17 default became Wayland. In either case, should be switchable from login screen cog icon.

1 Like


I realy don't have Wayland.

But, When I try via terminal or via icon in fact it's working but I have to wait 6 ou 7 minutes...
This is Brave :


2.06 PM

2.14 PM

So It's work but it's soooooooooooo slowwwwww

The same for Vivaldi :


2.14 PM


2.20 PM

Someone know anything about this errors messages ?

Do you have another linux distro installed in addition to Zorin or installed additional Desktop Environments (DE's)?
I don't understand why GNOME and MATE are listed as Windowing options on yout login screen from gear icon and that "MATE" is listed as your default setting (showing dot beside it). For ZorinOS I would expect just Xorg and Wayland options.

I don't have any other distro. I just install Mate and Gnome manualy to see if the browser works on this Desktop environement. Me too I expect just X11 and Wayland... Strange.

Installing additional desktop environments that use X11 can affect the ability select the Zorin Wayland option. I experienced this on Zorin 16 using Budgie. When removed an additional gnome option appeared in the list. To find out use the following command.
echo $XDG_SESSION_TYPE

If you've made changes to the system it's possible you accidentally removed or updated something that Chromium relies on. Something like Timeshift can be very useful here to revert system changes easily if you notice that something stops working suddenly.

You can also go into flags and try to enable/disable options related to graphics and hardware acceleration.

One of the warnings talk about this which may be related to performance:

https://www.intel.com/content/www/us/en/docs/vtune-profiler/user-guide/2023-0/set-up-system-for-gpu-analysis.html

https://wiki.archlinux.org/title/Intel_graphics

What it is I don't know but take a look at these pages and see if you're interested in enabling this kernel parameter. Read more about doing this:

https://wiki.archlinux.org/title/Sysctl

Hi,

I try all of this but nothing work.

I format the computer and It's the same.

But now it's working but with the installation via snap but with .deb and flatpak for the browser it's still stuck so... snap... strange.

And after reinstall I dont have any setting's wheel for change X11/Wayland... strange to.

Thank all of you.