Browsers Not Linking CSS Files from Mounted Drive

I could use some help trying to find out why my CSS files are not linking with my HTML files when opening from a mounted drive, only on Zorin17.

I am running a system with two SSDs (one for Windows, one for Linux) and a shared HDD for both of them to access. I recently upgraded from Windows 10 to Windows 11, and from ZorinOS Pro 16 to ZorinOS Pro 17. Ever since then, on only Zorin 17, when I open a .html file that is hosted on a mounted drive in a web browser (any web browser - Firefox, Brave, GNOME Web), it behaves as if it is isolated and cannot link to the CSS file. If I move these files to the SSD where Zorin17 is installed, they also open fine. The problem is only with ZorinOS 17 linking the files on the mounted drive.

  • Kernel: 6.5.0-14-generic #14~22.04.1-Ubuntu

  • The mounted drives are NTFS, which is where I assume the problem is coming into play. But I can read/edit/delete files just fine from Zorin17, just can't get the HTML/CSS to link anymore, like they did on Zorin16.

  • I verified ntfs-3g was installed.

  • As mentioned, I tried 3 different browsers, including GNOME Web which was freshly installed.

  • I created a test html/css pair and the issue persists there too. (I have in the head of my HTML document. (I have also tried "/style.css", which doesn't work either.))

  • I verified the file permissions allow anyone to read/write/execute. Also verified uid and gid match the user account I'm using.

  • The HTML and CSS files are in the same directory.

  • I tried three different mounted drives, all had the same issue, regardless of whether they are set to automatically mount or only manually.

  • I verified fast boot was disabled on Windows 11, as I know that sometimes causes issues with files that are accessed from both operating systems when dual-booting.

  • I tried removing 'noexec' or 'nosuid' from the mount options, then rebooted and re-mounted, but no change there.

  • I checked 'dmesg | grep ntfs' on Zorin, which gave me no output, so I'm assuming it found no errors.

  • I ran 'chkdsk /f' for one of the mounted drives from Windows, then rebooted back into ZorinOS afterward, but there was no difference.

Welcome to the Forum!

When You were on Win10 and Zorin 16 does that worked with Your HDD?

1 Like

Hi! Thank you!

Yes, when I was using Win10 & Zorin 16, opening the HTML files from the HDD worked fine, and the CSS was linked.

1 Like

Hmm ... To be honest, I had the same Idea that the NTFS-File System problematic. But when it works with W10/Z16 ... Maybe the newer Versions doesn't work together. Let's ask @Aravisian. Maybe he knows Advice.

1 Like

Zorin OS 17 introduced including Firefox as a Flatpak rather than the standard apt.

Flatpak packages are containerized and may be unable to read outside of their container.


So my advice would be to install Firefox ESR (Extended Service Release) Manually.
I show how I did it in this vimeo video on Zorin 17 Beta approx 2 mins 40 seconds in:

1 Like

Thanks everyone! Aravisian was right, it was due to Firefox being a flatpak. Problem is resolved now.


1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.