Bug fix for Killer AX500 Sound - Dell xps 9700 - Z10 pro

So, I'm having issues with the audio - specifically the bluetooth mic which is a common theme for Dell users. I've found a "fix" for this, but I am brand new to Linux (1 wk, so I have the knowledge of a toddler) and I'm really nervous about messing with firmware and kernels. However, I use my laptop for work and it's imperative that I get my Bluetooth headset mic working asap.

Can you please tell me if this is safe to do? Will I be able to reverse this if something goes awry? Any input, advice or guidance is super appreciated

`To bring up QCA6390, aka. AX500s, on Ubuntu 20.04 Focal, please first update your system BIOS to the latest version available.

And then you will need both kernel (either oem-5.6, or oem-5.10, or generic-5.11) and firmware with ath11k support:


  1. oem-5.6 >= 5.6.0-1039.43

$ sudo apt-get install linux-oem-20.04

linux-oem-20.04 meta package may upgrade to v5.10 soon, but it will still support ath11k.

  1. oem-5.10 >= 5.10.0-1010.11 (recommended)

$ sudo apt-get install linux-oem-20.04b

This meta package may cease to exist after 5.10 oem kernel transition. Use linux-oem-20.04 then.

  1. linux-generic-5.11

Enable ppa:canonical-kernel-team/bootstrap for Hirsute:

$ sudo apt-add-repository ppa:canonical-kernel-team/bootstrap
$ sudo sed -e 's,focal,devel,' -i /etc/apt/sources.list.d/ppa-canonical-kernel-team-ubuntu-bootstrap-focal.list
$ sudo mv /etc/apt/sources.list.d/ppa-canonical-kernel-team-ubuntu-bootstrap-focal.list /etc/apt/sources.list.d/ppa-canonical-kernel-team-ubuntu-bootstrap-devel.list

$ sudo apt-get update
$ sudo apt-get install $(apt-cache search linux-modules-extra-5.11 | awk '{print $1}')

Then rename the list to prevent unexpected upgrades:

$ sudo mv /etc/apt/sources.list.d/ppa-canonical-kernel-team-ubuntu-bootstrap-devel.list /etc/apt/sources.list.d/ppa-canonical-kernel-team-ubuntu-bootstrap-devel.list_
$ sudo apt update


Version 1.187.7 or newer is needed. So just do:

$ sudo apt-get install linux-firmware

Then reboot and check if wireless is now working. If doesn't, please file a new bug instead.

========== previous SRU justification header ==========

[SRU Justification: oem-5.6]


Qualcomm QCA6390 series not recognized due to the lack of ath11k and all
its prerequisite drivers.

$ lspci
0000:55:00.0 Unassigned class [ff00]: Qualcomm Device [17cb:1101]
Subsystem: Bigfoot Networks, Inc. Device [1a56:a501]


Tag ath11k-qca6390-bringup-202011301608 from ath tree
(kernel/git/kvalo/ath.git - wireless ath drivers tree, ath9k, ath10k, wil6210 etc) marks
first stable milestone on the platform/device under development since
v5.6-rc1. Most of the commits under this tag, ~350 commits, have been
in vanilla kernel v5.10-rc4 except those starting from commit
065c9528cc50 ("ath11k: add 64bit check before reading msi high addr").

While ath11k depends on MHI bus, qrtr and qmi helpers, changes falling
in these components are also pulled.

Besides, tx encapsulation
and a couple more inclusive of 6 GHz capability, BSS Color were also
pulled to satisfy API changes in mac80211/cfg80211.

[Test Case]

  1. Install firmwares & boot from patched kernel,
  2. ath11k should be now up and running. Check with
    sudo dmesg | grep ath11k

While this is going to bring massive changes to the kernel, as well as
shared wireless stack that is not only used by ath11k but also many
others, prebuilt kernel/firmware packages were deployed on platforms
with and without ath11k for regression tests, and so far the results are

[Where problems could occur]

ath11k and its relying parts have never been enabled in oem-5.6, so
changes to them should have little effect on most platforms. For
platforms equip QCA6390, this will be the first time they're probed and
enabled, and as the driver is still under polishing, there can be
regressions, performance lost, power consumption increase at this

Changes to wireless stack could also be an issue as this introduces
interface changes to the API, so maybe DKMS packages in the wild will be

This is the source for the info: Killer 500s (QCA6390) WLAN/BT [17cb:1101] unavailable


Everything there looks safe. :slight_smile:
If it does not work out, you can hold or tap the left shift key at boot to bring up the Recovery Menu at grub that offers Advanced options for Zorin. From there, you can select a Different Kernel to boot from. Once booted, you can remove any kernels you do not need or want.
Which is a life-lesson... Never remove all older kernels right after installing a new one.

Thanks once again @Aravisian . What about the firmware? Is there a way to restore it if it doesn't work?

In the O.P., you mention BIOS Firmware- this is dependent on the manufacturer, not Linux (Or Windows).
If you are referring to Linux Firmware... The short answer is; You don't need to worry about it. I have never once seen new installed Linux-firmware not work.

Okay then. I trust your wisdom. Off I go... fingers crossed, lol.

1 Like

Muhahhaha... all according to plan...

1 Like

Lamo! :face_with_hand_over_mouth:

1 Like

Ooookaaay... so that went horribly wrong! After doing the "bug fix" I had zero bluetooth. Rebooted as instructed and got back on the kernel from install, only now I still can't connect. I've uninstalled and reinstalled Blueman, but each time I try to pair it says, "Cannot connect - protocol not available"

Gah! Help?!!

If you restored back to the 5.11 kernel, can you run the following in terminal:

pactl unload-module module-bluetooth-discover

pactl load-module module-bluetooth-discover

Bluetooth is directly related to Pulseaudio... and you were initially having Audio problems.
Really, what you describe should not have happened... That's a weird one. But given the above relation, I wonder if it is also a clue.

Thanks for the rescue! Okay, so I ran both, and they both returned:

Connection failure: Connection refused
pa_context_connect() failed: Connection refused

But earlier, I had installed a ppa called pipewire based on an Ubuntu forum suggestion. Could that be the cause? I don't see how it could disable my bluetooth completey.

You may need to check if anything was blacklisted. I am heading out the door even as I type this so cannot take a moment to type out a lengthy post on each thing and how to- But using your Net Search should get you going or @storm or others can chime in.

Also, remove the pulse folder from ~/.config/ if it exists, then reboot and test.

Neither do I. I believe you mean you installed Pipewire, right?

Install Pulse Audio Volume Control

sudo apt install pavucontrol

Launch it with terminal command pavucontrol and check your Input, output and Configuration tabs.

1 Like

Check /etc/modprobe.d/blacklist.conf to see if the OEM kernel blacklisted any bluetooth modules.
Within /etc/modprobe.d directory, read the other file names present for any files that reference Bluetooth.

Oh my! I started to uninstall pipewire as instructed and as the terminal was running the uninstall, my computer crashed. Black screen. After a bit of messing around I can get the grub menu, but I can't get further than that. I'm just getting errors: PPM init failed (-110)

I'm trying hard to remain calm.

So, it seems this has to do with missing Nvidia drivers. I have booted through the live usb, but I have zero knowledge of where to go from here.

How do I install the missing drivers into main OS from here?

Are you able to remember clearly what you uninstalled? What the command was?
It looks as though all video drivers were uninstalled given that error.
"as instructed" - Which instructions were you following?

You remember bapping the Left Shift Key to pull up Advanced Options for Zorin? Do that on your system (Not the LiveUSB Demo) and arrow key down to "Enable Networking"
Then back up the recovery menu and arrow key down to drop to prompt
Hit enter...
Then type in:

sudo ubuntu-drivers autoinstall

If it successfully completes, continue to boot normally to test...

I've tried 3 times to get into the advanced options but pounding the shift key does nothing. It just continues to boot to the regular grub then to errors. IDK what the heck is going on. Is there another way to access the advanced menu?

I'll share the link if I can ever get back into my laptop. It was something like: sudo apt-get uninstall ppa:pipewire How in the world could this uninstall all my video drivers? Gah!

What to do now? Is there someway to access the tty screen and do it from there?

This shouldn't have done anything, really.
The proper command to remove a ppa is

sudo add-apt-repository --remove ppa(Whatever the ppa address is)

To remove software, it would have just been

sudo apt remove pipewire

Really, the command should have just given a terminal message that said "ppa:pipewire is not installed, so was not removed" or something like that.

You can only access tty if you are able to run init- which if you cannot boot, you may not be able to run init.

How do I install drivers from the tty screen? I have to try. I just can't lose my entire install.

It would be the same commands as above- the trouble is in accessing tty.
This guide may do better than a forum post:


Some days... living just ain't workin' out...

My spidey senses were tingling before deciding to update the kernel and firmware. Luckily, I created a timeshift image right before I did it. Hopefully, I can restore it.

Really appreciate all your help. :innocent: We need more people like you in this world.

1 Like