[BUG] GUI crashing on zorin Os lite and Zorin Os 16.1 Core. Most problema installing Zorin 16.1 Core

This topic is only a bug report.
Problem 1: I was using Zorin OS lite that I had installed since 2020 (maybe the version 14), and had all the updates mades (I think that they changed my version to the actual, lite 16). In the last week, the OS locked (I'm not an english native, so I don't know the right term to tell that the notebook don't answer any command, like paralyzed) when I tried to call the window to turn off the laptop. Therefore the GUI broken started to broken everytime I used it.

Problem 2: So I tried to change to the 16.1 Core, and it started to paralyze somtimes in the USB installation, especifically in the packages install window, before the HD/SSD partition window. Other times it goes normal.

Problem 3: The GUI crashing problem occurred on Zorin 16.1 Core, but this time I don't know how it started, it only happened sometimes that I was using the OS.

Notes: Finally I had installed the Ubuntu 22.04 and it's paralyzing too. I know the Zorin is based on it, maybe there are any relationship between the bugs.
My hardware: Dell Inspiron 3583, with i5 octave edition (the product manual don't clear the exact type of the processor) and 8 gb RAM.

Sorry for mine english mistakes.

The first things that come to mind:

  • BIOS Update availabel for Dell Inspiron. Installing the BIOS Update may resolve the issue.
  • Bad RAM. Test the RAM and clean the sockets.