BUG - option boxes dont work/unable to see them

Hello, I switched to the new version of Zorin and found that option boxes appear with a gradient of colors and I can't see for example the contents of "Bookmarks" as shown on the Image. At first I thought it was a bug from the installation of Zorin, so I re-did the installation from 0, but the problem persists.

Is the problem limited to Brave browser, or do you see it elsewhere?
If just Brave, how was Brave installed e.g. Snap, Flatpak, .deb etc ?

1 Like

At first I thought It was brave, but the past days I have seen it in Helvum, firefox...

How did you install those app's, e.g. Snap, Flatpak, .deb etc ?

1 Like

snap, some from the terminal and some through the software app, but I have some other apps from snap that work fine

Running snap and or flatpaks can sometimes be problematic. Try the install Brave via their pages instead and test it:


I already tried that the second time I installed Zorin, also re-did the bootable usb to see if the ISO was the problem

That looks like a Graphics issue.
What Graphics are you using?

It would make sense if using Snap or Flatpak, that the package would be unable to access system graphics.


I have a Gtx 1650, I used the "install Zorin with Nvidia drivers" option, shouldnt it be enough with that?

Any Nvidia driver between 470 and 525 should work well with that card.
Which kernel are you on?

uname -r

Kernel: 5.15.0-84-generic

How Do I know which driver I have installed?

Launch Software & Updates from the app menu or from alt+F2 and entering in software-properties-gtk

Move to the Additional Drivers tab.
Note which driver you are using. I recommend trying the 470 driver first and rolling back to the 5.15.0-83 kernel to test it on.
You can roll back the kernel by Rebooting- tapping esc or tab to pull up the Grub menu and selecting Advanced Options for Zorin and choosing Zorin on 5.15.0-83

ok, I will try that

So, New problem. I selected the 470 driver and restarted the computer, the trackpad,wifi & keyboard shortcuts did not work that time but the issue from the colors was solved. I then tried it from the -84 kernel and the 3 new problems dissapeared but the colored boxes started again. Now my computer only works if I boot from the -84 kernel, the 78 and 86 both dont have wifi or trackpad :slight_smile:


So it looks like you have two divergent pieces of hardware - some that need newer kernel support and some that need older kernel support.

Really... it comes down to the graphics card being the primary culprit here, though.
Or at least, Nvidias greed in dropping support for their own cards.

This one may boil down to needing to upgrade your graphics card.

Well, Its a laptop so not much I can do :sob: It worked fine when using dual boot with Windows though, The zorin version was an older one, I think the one from 2022. With that installation I had no problems, I just wanted to fully delete windows and start from 0 so I installed the new one

Zorin OS 16.1?

I don't know exactly which version, it was late 2021/almost 2022 when I installed it, so thats Why I think its a bug from the new version.

Trackpad, keyboard and Wifi all worked as well as no Graphics glitches?

Could Four things have regressed in later kernels? That would be a stretch but...
Maybe test the 5.13.0-28 kernel that dates to the release of Zorin OS 16.1 and be sure...

sudo apt install linux-headers-5.13.0-28-generic linux-modules-5.13.0-28-generic linux-modules-extra-5.13.0-28-generic linux-image-5.13.0-28-generic

Ok, I will try, thanks for the help