BUG REPORT: Latest update removed all Desktop icons

The updates today removed all the icons on the Desktop, and somehow wiped /var/log/dpkg.log and /var/log/apt/history.log, which only became apparent after a reboot!

So I can't tell you what was installed, but one of them was about desktop icons, so...

The Zorin-specific, desktop-specific packages I've got installed:

gnome-shell-extension-zorin-desktop-icons/focal,now 0.18.2 all [installed,automatic]
Desktop icon support for GNOME Shell

gnome-shell-extensions-zorin-desktop/focal,now 3.4 all [installed,automatic]
Zorin Desktop extensions

zorin-appearance/focal,now 4.1.12 all [installed,automatic]
Modify the look and feel of your Zorin OS desktop

zorin-appearance-layouts-shell-core/focal,now 3.0.3 all [installed,automatic]
Zorin Appearance - Layouts Shell Core

zorin-appearance-layouts-support/focal,now 3.3.2 all [installed,automatic]
Zorin Appearance - Layouts Support

zorin-auto-theme/focal,now 1.4 amd64 [installed,automatic]
Daemon to automatically change the theme

zorin-desktop-session/focal,now 4.2.3 all [installed,automatic]
Zorin Desktop session for GNOME

zorin-desktop-themes/focal,now 3.4.5 all [installed,automatic]
Zorin OS desktop themes

zorin-os-desktop/focal,now 1.5.14 amd64 [installed]
The Zorin OS desktop system

1 Like

All desktop icons as in, only program shortcuts, or even regular files that you keep there. Can you still see them if you navigate to ~/Desktop through the terminal?

Every icon on the Desktop... Trash bin, Computer, drive icons, icons for the files I'd put there... the files are still there in Nautilus, though.

I attempted:
sudo apt reinstall gnome-shell-extension-zorin-desktop-icons
... then went into Zorin Appearance > Desktop, and disabled then re-enabled "Icons on Desktop", but it didn't change anything.

Does gsettings set org.gnome.desktop.background show-desktop-icons true change this for you?

If not, which desktop environment (DE) are you using?

Since you mentioned this problem doesn't exist while using Nautilus, did you perhaps make any changes to your DE, such as enabling another File Manager and changing file associations to allow showing of desktop icons?

I ask because if I remember the order of events correctly, while being unaware that there was an integrated way to show desktop icons in Zorin, I previously tried to make a change to my DE allowing me to use nemo as my file manager, and nemo-desktop to allow automatic switching default GNOME/Zorin desktop to better integrate with the desktop icons I wanted. The reason I added the nemo-desktop caveat is because I ran into a problem which involved the desktop losing the desktop icons after reboot until I activated them again through use of the command gsettings set org.nemo.desktop show-desktop-icons true. I believe this was the result of the fact that Nemo FM was set aside as GNOME's default file manager in favor of Nautilus, which seems to be a code-compatibility issue that was never patched in Nemo or GNOME DE. Either way, I don't want to hijack with too much conjecture on a possibly unrelated problem so I will stop there.

If you are using a different DE, I can't speak to the method you would take to make the above commands work in similar fashion, but that may be quickly resolved with a quick search online if the issue is now pointing in the direction of a desktop environment switch-related cause.

DConf Editor is a nice way to delve into the options to configure application-specific characteristics. Take care to not change anything without obtaining knowledge of what exactly you are modifying. GitHub link.

I provide the links above because it is a nice, categorized and GUI-based way to browse/search through all options related to specific strings of text; for instance, "icons", for specific application settings, and even for some you did not know existed which may be hidden for one reason or another. You can also find the current state of configurations if you know you're already looking for something having to do with settings of the gnome.desktop variety, or other desktop environment settings.

I'm running Zorin and Gnome and Nautilus. I haven't made any changes to the DE, nor to the file manager. I haven't attempted to install any other DE or file manager.

I always reboot after any update, and when I rebooted after today's update, all the desktop icons were gone.

I've already looked at Dconf Editor... desktop icons are enabled, they're just not showing up, for some reason.

gsettings set org.gnome.desktop.background show-desktop-icons true doesn't cause any change... I think the latest update borked the gnome-shell-extension-zorin-desktop-icons package somehow.

The only other thing that occurs to me to ask is: do you use Synaptic? Maybe you can completely remove the package and any configuration settings for gnome-shell-extension-zorin-desktop-icons?

If you don't use Synaptic, or don't want to or can't find the package for some reason, you can try to purge and reinstall via terminal if you want?

  • Purge the package using the following command:
    sudo apt-get purge gnome-shell-extension-zorin-desktop-icons

  • Remove any remaining configuration files using the following command:
    sudo rm -rf /etc/zorin-desktop-icons
    You can also search around in the root directories with your favorite file manager for these remaining files to manually purge, just in case you are justifiably hesitant to issue commands found online that begin with sudo rm -rf

  • Refresh the package list using the following command:
    sudo apt-get update

  • Reinstall the package using the following command:
    sudo apt-get install gnome-shell-extension-zorin-desktop-icons

This should completely remove the configuration of the package and reinstall it with the default settings.

Dependencies prevent my removing gnome-shell-extension-zorin-desktop-icons.

sudo apt remove gnome-shell-extension-zorin-desktop-icons
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
gnome-shell-extension-zorin-appindicator gnome-shell-extension-zorin-menu gnome-shell-extension-zorin-printers gnome-shell-extension-zorin-taskbar gnome-shell-extensions gnome-themes-extra gnome-themes-extra-data gtk2-engines-pixbuf xdg-desktop-portal xwayland
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
gnome-shell-extension-zorin-desktop-icons gnome-shell-extensions-zorin-desktop zorin-appearance-layouts-shell-core zorin-desktop-session zorin-os-desktop
0 upgraded, 0 newly installed, 5 to remove and 0 not upgraded.
After this operation, 544 kB disk space will be freed.
Do you want to continue? [Y/n] n

That would break things badly.

Actually, I think that might be the problem... that file isn't there.

What kind of file is it, and what are its contents? Is it a configuration file?

Something that stood out to me is:

I don't know what that is, but there's a chance the issue lies with that package. Are you opposed to reinstalling that? Nevermind... :slight_smile:


If you have broken packages and can't proceed with removal or install of that singular gnome-shell-extension-zorin-desktop-icons package, you can use Synaptic for a quick way to fix broken packages with a menu option in the "Package" drop-down. Another way to do this is to run sudo apt-get install -f before then running the install/remove/reinstall commands.

On the mention of "reinstalling", I'd like to see if you can just move forward with the command sudo apt-get install --reinstall gnome-shell-extension-zorin-desktop-icons. This shouldn't require fixing dependency issues that may arise. Though to my knowledge, this doesn't purge configuration files. I also do not know of a way to include the --reinstall flag with a purge or remove command.

If you are afraid of losing the packages which were "automatically installed and are no longer required" you can change their installation flag to manual if you want. I usually only do this using Synaptic menubar drop-downs but I think you can do the same thing with sudo apt-mark manual <package_name>. This will get rid of those messages for packages you want to keep installed after you make changes to other system packages which installed them as a dependency.

I should have said in my previous post too: is important to note that after making any changes (to include re-installation of the package, I believe) you should log-out and log back in before you expect to see any changes. You can also do a quick Alt-F2 and type r in the prompt to reload the GNOME shell. Thanks to @Aravisian for teaching me that back in the day.

It is one of the places a configuration file might exist for that extension package, yes.

If you don't find any configuration files in /etc/zorin-desktop-icons or that directory doesn't exist, any other configuration files for the application package zorin-desktop-icons should be in the /usr/share/gnome-shell/extensions/zorin-desktop-icons@zorinos.com directory. You can also run sudo find / -name "*zorin-desktop-icons*" to see a terminal output showing all locations, including directories, which contain that string of text.

If not already shown, change the File Manager's sorting bars so that you can see the Modified Date and check to see if recent modifications have been made to any of the configuration files in the directory. Might point to the culprit file you need to edit and/or re-install; though, this should have been taken care of during a purge of the package's configuration files.

Again, the next suggestion should have also been covered by complete removal or purge of the zorin-desktop-icons package and reinstall; but I wonder if maybe permissions of the configuration files might be an issue. To be honest I don't really know how user-level permissions would stop a system application package from working either. Try ls -l after navigating to /usr/share/gnome-shell/extensions/zorin-desktop-icons@zorinos.com?

Lastly, I can say that from what I've read, the zorin-desktop-icons extension - like most others - use a JS file called extension.js to control the behavior of things like the desktop icons. Possibly you could take a look in there with a text-editor or Vim-like application to view the file for lines that stand out.
For instance, in my extension.js file for the zorin-desktop-icons package, I see some code at line 7 in Vim, or 36 in a text editor showing the following: data.isEnabled = false; - though I should warn you that just because mine shows false doesn't necessarily mean yours should say true because you want to show your desktop icons, while I currently don't have mine set to show.

Nope, I've just got .js, .json and .css files in that directory, no configuration files. The modification date on all of them is back in 2021, so they're the original files.

sudo find / -name "*zorin-desktop-icons*"


Which are the configuration files? Does that package use a .conf file?

/var/lib/dpkg/info/gnome-shell-extension-zorin-desktop-icons.list shows all the files for that package... they're all in the places they're supposed to be, and none have been recently changed.

This is a strange malfunction... all the files are in place, the settings in Dconf Editor /org/gnome/shell/extensions/zorin-desktop-icons are correct, yet the desktop icons don't show.

Based on your codepaste above, it's probably safe to assume that any of those files in the .../snapshot/... directories are for backup/restore purposes and can be ignored for the purposes of locating your config files. The .../locale/... directories can also be safely ignored due them being for language translation purposes. The .../lib/... directories are just locations for library files which the extension might use to reference, or piggyback, system resources, the code of which should be provided by the system and are generally there to allow multiple applications to share the same code, reducing duplication and conserving memory.

Also based on your paste, the only other place of interest I can see is the normal usr/share/gnome-shell/extensions/zorin-desktop-icons@zorinos.com folder which consequently has all the configuration files needed for the extension to run.

Regarding a particular file to look out for within /usr/share/gnome-shell/extensions/zorin-desktop-icons@zorinos.com, the extension uses a JavaScript file extension.js to control the behavior of the desktop icons. However, take great care when even looking at these files, as any modification of these file-types should be done with caution as it may cause the extension to stop working properly. It's generally recommended to only modify the settings through the extension's configuration file.

The configuration file for a GNOME Shell extension on Zorin OS is typically located in the extension's folder under the /usr/share/gnome-shell/extensions/ directory. The name of the configuration file usually starts with the name of the extension, followed by a .conf extension.
That said, if you cannot find any .conf files in the directory of an extension like me, it's possible that the extension does not use a configuration file or stores its configuration elsewhere. As to where that would be, I have no clue and would have to defer to one of the devs or those with greater amounts of knowledge on these extensions, like @Aravisian or @zorink.

There might be documentation we could check, but I don't know where that's located either.

Alternatively, you can try using the GNOME Tweak Tool, JustPerfection(maybe) or a similar tool to configure the extension's settings.

In summary, all of my responses demonstrate the extent of my knowledge on the subject of troubleshooting extensions. Also, most of what I provided was given to merely identify the problem and I don't suggest delving further into source code and changing code as a form of troubleshooting the issue futher.

Methinks I've got it:

21:30:00 gnome-shell: DING:
(gjs:147687): Gjs-CRITICAL **: 21:30:00.456: JS ERROR: Error: Requiring Clutter, version none: Typelib file for namespace 'Clutter' (any version) not found

How do I install clutter?

I've got the following clutter-related packages installed:

gstreamer1.0-clutter-3.0/focal,now 3.0.27-1 amd64 [installed,automatic]
libclutter-1.0-0/focal,now 1.26.4+dfsg-1 amd64 [installed,automatic]
libclutter-1.0-common/focal,now 1.26.4+dfsg-1 all [installed,automatic]
libclutter-gst-3.0-0/focal,now 3.0.27-1 amd64 [installed,automatic]
libclutter-gtk-1.0-0/focal,now 1.8.4-4 amd64 [installed,automatic]

I just used my script:
gnome-terminal -- /bin/sh -c 'echo Updating; sleep 5; sudo apt update; sudo apt full-upgrade; sudo apt dist-upgrade; sudo apt-get upgrade; sudo fwupdmgr refresh --force; sudo fwupdmgr update; sudo flatpak repair; sudo flatpak update; sudo snap refresh; sudo apt autoremove; sudo apt autoclean; sudo apt purge; sudo apt update --fix-missing; sudo apt install --fix-broken; sleep 30'
... to check for updates. There are no updates. There's got to be some malfunction introduced by today's updates that makes zorin-desktop-icons not see clutter properly.

sudo apt-get install --fix-broken libclutter-1.0-0

sudo apt-get install --fix-broken libclutter-1.0-0
Reading package lists... Done
Building dependency tree
Reading state information... Done
libclutter-1.0-0 is already the newest version (1.26.4+dfsg-1).
libclutter-1.0-0 set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Could the error be that the latest update used 'Clutter' (upper-case C) (which is what the error message in the logs is looking for), whereas the clutter package uses 'clutter' (lower-case c)?

Could that be why zorin-desktop-icons thinks there's no version of clutter installed?

You could try, sudo apt-get install --install-recommends --install-suggests libclutter-1.0-0 to see if anything else is installed. If you use those flags though, ensure you do so sparingly or you might end up with a load of unwanted packages which you truly do not need for most occasions.

If that doesn't work for you then I highly recommend getting Synaptic Package Manager and searching for libclutter. If you right-click on the libclutter package search result, you can click "Properties" and show all the dependencies, recommended and suggested packages that are thought to work well with that particular package. Or, I would just recommend the alternative of re-installing it, also after a right-click, which may prove useful. Myself; I have libclutter-1.0-0, libclutter-1.0-common, libclutter-gst-3.0-0, and libclutter-gtk-1.0-0 all installed.

sudo apt show libclutter-1.0-0

Package: libclutter-1.0-0
Version: 1.26.4+dfsg-1
Priority: optional
Section: libs
Source: clutter-1.0
Origin: Ubuntu
Maintainer: Ubuntu Developers ubuntu-devel-discuss@lists.ubuntu.com
Original-Maintainer: Debian GNOME Maintainers pkg-gnome-maintainers@lists.alioth.debian.org
Bugs: OpenID transaction in progress
Installed-Size: 1,666 kB
Depends: libatk1.0-0 (>= 2.5.3), libc6 (>= 2.29), libcairo-gobject2 (>= 1.10.0), libcairo2 (>= 1.14.0), libcogl-pango20 (>= 1.17.4), libcogl-path20 (>= 1.17.4), libcogl20 (>= 1.21.2), libfontconfig1 (>= 2.12.6), libglib2.0-0 (>= 2.53.4), libgtk-3-0 (>= 3.16.2), libinput10 (>= 0.21.0), libjson-glib-1.0-0 (>= 0.12.0), libpango-1.0-0 (>= 1.30), libpangocairo-1.0-0 (>= 1.30), libpangoft2-1.0-0 (>= 1.30), libudev1 (>= 183), libwayland-client0 (>= 1.9.91), libwayland-cursor0 (>= 1.0.2), libwayland-server0 (>= 1.2.0), libx11-6 (>= 2:, libxcomposite1 (>= 1:0.3-1), libxdamage1 (>= 1:1.1), libxi6 (>= 2:, libxkbcommon0 (>= 0.5.0)
Recommends: libclutter-1.0-common
Breaks: cinnamon-session (<< 2.6.2)
Homepage: Clutter Project – Have fun!
Task: ubuntu-desktop-minimal, ubuntu-desktop, xubuntu-desktop, ubuntustudio-desktop, ubuntukylin-desktop, ubuntu-mate-desktop, ubuntu-budgie-desktop
Download-Size: 534 kB
APT-Manual-Installed: yes
APT-Sources: Index of /ubuntu focal/main amd64 Packages
Description: Open GL based interactive canvas library
Clutter is an Open GL based interactive canvas library, designed for creating
fast, mainly 2D single window applications such as media box UIs,
presentations, kiosk style applications and so on.

You could be right, but since I didn't have the same problem (mostly due to my avoidance of using desktop icons), I can't really provide affirmation here.

I have been thinking we might be going down a rabbit hole here so I will pause my contributions to the thread in favor of another person's valued opinion or expertise. Not that I had much else to offer though, as I will say again, I've exhausted most of my limited knowledge of packages/extensions and troubleshooting problems in Linux altogether.

I'm going to ping @Aravisian and @AZorin... they'll be able to get this sorted.

1 Like