Bug with VLC player and the file window

I'll let the picture do the talking here. I think it's self-explanatory. But yeah - when I click on "open" in VLC using the file menu, the window opens behind VLC, and not in front of it. It's a bug, methinks. Also, it should be opening directly in front of the media player, not to the side. Please fix. Thank you very much. @staff

Also - this is on Zorin OS 17 Pro. (Thanks again.) @staff

I'm not sure if this is perhaps an issue with Gnome or even VLC itself, as I have the same behavior on Debian 12. I also tried it quickly on both Xorg and Wayland, and even tried installing the Nemo file manager but without any change.

Didn’t have this issue at all on Mint.

SpiralLinux with XFCE also has the same problem, I wonder what Cinnamon desktop is doing differently. I also found this thread reporting the same issue dating way back, even on several versions of Windows.


1 Like

Interesting. Well, if Mint can do it, so can Zorin. Let's hope.

It seems I misunderstood the problem. What I've tried is to play a video by right-click -> Open With Another Application -> VLC Media Player. What this does is that it brings up VLC to the foreground if it's not already running, however if there's an instance of VLC already the video plays but the player remains unfocused behind the current file manager. This is the behavior that I've seen in all my tests, including just now with Mint 21.2 Cinnamon.

But I've re-read your original post and it looks like you're talking about the file picker, when you go to VLC -> Media -> Open File. Is this correct? If that's the case, it seems to be working just fine; using the keyboard shortcut Ctrl+o also works:


If not, could you please clarify what the issue is?


You said, "But I've re-read your original post and it looks like you're talking about the file picker, when you go to VLC -> Media -> Open File. Is this correct?"

Yep. But what you showed in your GIF is not what's happening with me. Odd.



After I re-watched your GIF, a thought occurred to me. I went to the software center in Zorin OS, and uninstalled VLC through it. The Flatpak version was installed. I got rid of that. I then reinstalled VLC, but the APT version. Boom. Everything worked flawlessly after that with the file picker window. Interesting. Problem solved, I guess, but maybe now the ZorinGroup can look at including the APT version by default instead of the Flatpak one (or at least investigate why the Flatpak version was problematic). Thanks!

(EDIT: For whatever reason, I can't mark this as the solution. Weird.)


if you want all app windows to open at the center of the screen, i know a way to do it.

sudo apt install gnome-tweaks

Tweaks -> Windows -> Center New Windows.

I agree that Flatpak as the default package format is troublesome more often than not. I tried using VLC at first but then forgot to repeat the same test once I understood the issue.

I've changed the category from Feedback to General Help which should now give you the option to mark one of the posts as the solution. While it's good feedback, rest assured this has been brought up many times :smiley:

If you are curious, there's a discussion open on this thread:

I already have Gnome Tweaks installed; thanks. Also already have "center new windows" set. I appreciate the thought. I wish ZorinGroup would integrate this functionality into Zorin OS, though. It would make so much sense.

Thanks for the link to the discussion you referred to. Interesting, indeed.


The bug with VLC player is still happening in Zorin OS 17.1.

How to fix this? Is there anything the Zorin Group can do?

Also - the current APT version is no longer able to play DVDs. Weird. Only the Flatpak version can play DVDs now. Help? (Thanks.)


Reinstalled the libdvdcss library through the terminal output. This was done with the APT version of VLC available via Zorin OS. After following the steps for the libdvdcss library here, VLC worked. Not sure what the problem was after 17.1 hit. (Something for the Zorin Group to look into.) Hope this helps someone, too.

1 Like