Camera doesn't work

I have Lenovo S340-14API and Zorin 16. Webcam does not work. I tried cheese and VLC, both report error. E.g. VLC shows "VLC is unable to open the MRL 'v4l2:///dev/video0'. Check the log for details."
As I remember right after installation it worked (tested in browser).

1 Like

Hello and welcome to the forum.

Now that you have posted this issue, I have realized that I have the same problem too. Just went to vlc to record a video and check if I had that issue and I had the same problem as you do.

Now getting to the solving part. Did you install vlc as snap. If yes then follow the below steps.
•Open terminal and type snap connections vlc
•Then check in the camera part if the slot is blank.
•If yes then type and run snap connect vlc:camera :camera

That fixed the vlc issue for me.

1 Like

What error does cheese show?

I installed vlc with apt install. Cheese just write "There was an error playing video from the webcam". I


Screens attached.

1 Like

What output do you get when running cheese from the terminal?

1 Like

Hello again :wave: Just installed vlc as apt and I got the same error too. But mine was fairly very easy to fix. Do you have /dev/video1 option when going to

Media >Open Capture Device > Video device name

I have two cameras one as /dev/video0 and the other as dev/video2. By default, mine is selected as /dev/video1which shows the error and the other two doesn't. If you have the other one try using that one and check if it works.

1 Like