Can anyone help me solve the read-write permissions issue?

First of all, I switched to Zorin yesterday from Windows 10, and man I love the freedom to customise everything and overall, the performance is just next level. Thank you so much @team Zorin for creating this wonderful on-boarding experience for newbies like me.
Now, coming to the problem, I was trying to save a text file to one of my two drives, but it displayed an error.
Here's the error message:


Also, my laptop has 128 GB SSD, where I installed Zorin OS, and 1 TB of other drive, divided into few sub-drives. This 1 TB drive has read only access from what I understand from the error message. How can I change the permission from read-only to read-write?
I have attached the screenshots from the "Disks" app.

2 Likes

Hold CTRL ALT F2 to enter Terminal.

Now type Sudo Nautilus

Enter your password......

Find the drive that you are using on the left side of the window list. Right Click then click on Properties

Go to the Permissions tab

Change Owner and Group to the username that you chose in the OS.

Make sure Access is set to Create And Delete Files

Click on Change Permissions For Enclosed Files

Make sure that Owner is set to Read And Write as well as Create And Delete Files

Click on Change

Now close the Nautilus window, then close the terminal APP. Your drive permissions should be all set now, and you should be good to go.

Hope this help!

PS: Thank you for choosing Zorin OS 16 :slightly_smiling_face:

5 Likes

Hey, thank you so much StarTreker for the quick and detailed explanation.

I followed your exact instructions, but the problem is not getting solved.
I've attached the screenshots of the settings.

Screenshot from 2021-09-18 18-30-57

Is it because of the previous windows 10 settings? (I am completely running Zorin without dual boot)
Also, would formatting the entire drive solve this problem?

Thanks again for your help. :slightly_smiling_face:

3 Likes

I saw the beginning of this 1 TB drive has "Microsoft reserved" partition". Unless you are dual booting Zorin with Windows, I think it does not have to be there.
@Aravisian might be able to confirm this.

4 Likes

I formatted the entire 1 TB drive (after taking external backup) and it no longer has "Microsoft reserved" thing. Instead, it has been labelled as "unallocated Space" Can you help me allocate this drive for my regular read-write operations?

Here's the screenshot after formatting the drive.

2 Likes

Certainty :slight_smile:

  1. Click on the gear :gear: icon on the bottom left.
  2. From the drop down list select the 1st item "initialize partition".
  3. In the Window that opens, give a name for that drive (such as Data, for example).
  4. If you are planning to use this drive exclusively in Linux, select Ext4 as a file format. If you want to share the drive with Windows you need NTFS format. Since FAT has a 4 GB file size limitation, it is not very practical.
  5. Click to confirm to start initialization.

Depends on your PC power, it may take a while for the entire 1TB to be formatted. Just be patient and never interrupt it. If you are using laptop, I recommend you to plug the machine while performing this operation.

3 Likes

Thank you sir! It would take about 5 hours to complete the job. Thanks for helping me out!

Also, here's the screenshot.

2 Likes

I am glad to hear that I solved your problem :slight_smile:
All looks good in the screen shot.

By the way, you got my gender wrong :girl:

1 Like

You and other tech support members were super helpful and I promise that I will help the community in some way.

Regarding your gender thing, I'm so sorry. And it is much appreciated that women like you are active in tech.

Peace :peace_symbol:

2 Likes

It is easier than one would think.
There is always someone who does not know what you already know :slight_smile:

Sharing knowledge helps not only the person who has asked the question but also many future visitors who might have the same question.

Thanks for the encouraging words.
I hope more people would understand that there are such thing as female nerds :nerd_face: albeit being a minority in this male dominant field.

1 Like

Interesting thought!

I'm all in :100: :raised_hands:

3 Likes

Dragon, I am returning after getting a little bit of sleep, and dealing with a power outage. Life has been interesting over here to say the least lol. I just wanted to quickly say, that I am happy that we were able to help you out with all this.

I am also happy to hear that you are willing to stick around to help others, that is a very nice thing to do, and I want you to know that I appreciate it. I have always believed that, when knowledge is shared, everyone benefits. :+1: :wave: :+1:

2 Likes