Can install 16.3 but not 17

I've been running 16.3 successfully on a HP ProBook 6730b for a while. Today I tried to make a fresh install with 17 but when I press Esc during boot to reach alternatives nothing happens and I can't proceed to boot order och BIOS setup. Same thing with F9, F10 etc.
I then tried install 16.3 and it boots fine, went back to 17 and it hangs again.
I've tried various settings in BIOS and downloaded 17 again.

Any ideas?

It sounds like either a corrupted download (you can check by letting it run through the check during setup) or your BIOS is set to boot to UEFI only and your USB (I assume) format is not compatible.

I'd suggest either using Rufus and choose UEFI or BIOS option under the Target System or using Ventoy.

No, it isn't corrupted - it will install on another machine.

I've always relied on Balena Etcher but tried with Rufus and chose FAT32 (which doesn't seem to be an option in Etcher) - and it worked. Thanks!

Did you install it from Try to boot into the installer with safe graphics.

If nothing works, wait for the Z17 Upgrader to arrive in the coming weeks to install Z17.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.