Can not Zorin OS Lite 16.3 share files and folders?


I have Zorin OS Lite 16.3 on several computers, and I can run nearly everything I want to run on them. I use a Windows 10 computer as a fileserver, and I use cifs-utils to connect to it.

I want to replace the Windows 10 with Zorin, but I cannot share folders from Zorin OS Lite 16.3. Is it impossible to do that on that Lite version? It is a mess with all new and old instructions I have found. I have tried with ”sudo apt update && sudo apt install samba -y”, ”sudo systemctl restart smbd”, ”sudo apt-get install samba samba-common system-config-samba python-glade2” (which results in error messages for system-config-samba and python-glade2) and ”sudo apt install smbclient python3-smb”, but nothing I do works to get the menu option ”Local Network Share”.

Can you please help me and tell me what I shall do? It will also be great if someone can remove all instructions that does not work and replace them with working ones. I do not want to mess up my installations more with just testing different things without knowing.

Thank for your guidance.

Hey! I don't use file sharing, but I know that on XFCE (Zorin Lite) it is possible, I'll (and you can too) search on the internet about how to do it on "xfce"

Now I have found a new menu option in Utilities named Filer, also known as Nautilus, above the standard Thunar File Manager, and it contains the menu option ”Local Network Share”! I have got it to work on one computer and I have been able to share a folder with files that I could connect to from both other Zorin OS Lite and Chrome OS Flex computers.

The problem now is that I do not know when in all attemps the Filer was installed, and I have tried to do the same on an older and slower Zorin OS Lite, but I do not get the Filer in the menu automatically. I have tried to install it from both Software and the Terminal with the command ”sudo apt-get install nautilus”, and they both works but no one of them contains the menu option ”Local Network Share”. Perhaps the computer is to old and slow, I do not know.

Is it anyone who understand which of my attempts that was right and worked, and gave me the Filer with the wanted menu option? I think that I am not alone to have these problems, and all will be happy if it will be official working instructions uploaded on this site. The problem is that there is now too many old instructions that do not work or are unnessesary complicated. I have obviously got it to work on one Zorin OS Lite computer only with this.

Best regards

if you load in synaptic package manager, you'll find out that thunar has a few addons for network connections and possibily shares as well.