Cannot acces HDD from zorin installer

Hello. I cannot access my hard drive from zorin installer or live environment. Im running a Acer A315-56(Windows 11). I've tried a few solutions I've found from browsing the internet but nothing works yet. Here is everything I've tried in order.
1: Created new partitions on hard drive in ext4, NTFS.
2: Tried different usb ports.
3: Used a different usb tried usb 3.0 and 2.0
4: Formatted HDD in ext4 and set root to /:
5: Disabled Secure boot
6: Disabled Fast Startup and Quick Boot
7: Put HDD in different PC and installed Zorin 16.1 (it worked fine)
8: Plugged it back into and laptop tried to boot(I get an error.
-Boot args (cat /proc/cmdline)
-Missing modules (cat /proc/modules; is /dev)

Please I need help fixing this, I really don't want go back to windows it's been giving so many problems.

In live mode of Zorin can you please run gparted and take a screenshot and post back here.

That looks like you have somehow installed the iso, not Zorin 16 itself.

I used balenaEtcher to flash the the iso to my usb drive

Etcher has been known to have issues. I would try Ventoy instead. Did you check the SHA256 key of the downloaded Zorin iso?

No I haven't, but but I'll re-flash onto a different drive with Ventoy

It wasn't after start pc push button shift to go menu Zorin. Your hard disk is empty. Show a size but on gparted nothing how much place taken installation and how much free. Don't seeing partition. This is like Zorin installed on pendrive.

Check this out and see if it helps :smiley: :-

5 Likes

I didn't have any issues with Etcher when I burned the Zorin iso to my USB. I did this multiple times and no issues.

The hard disk is the same or new?
If you changed in laptops nvme ssd some motherboards recognized some types but not all types hard disks. Propably the distribution don't recognized your hard disk. On bios you need AHCI and and off UEFI. I don't know to much from here this is lottery. Many advice but no solution step by step.