Cannot access BIOS setup on laptop

Hi all. I wanted to refresh an old laptop, so I want to run Zorin on it. But I need to have Windows 10 installed too for a specific UWP app.

I set all my partitions on the laptop and installed Zorin on the ones I wanted to, I also left some unallocated space for Windows 10 to be installed on.

I have come to install windows today. But I can't get the USB stick to be recognised. I have tried UNetbootin and Rufus to create the bootable media with the Windows 10 iso.

When starting up I see options: F12 for Boot menu and F2 for BIOS setup.

The boot menu only shows "1. ubuntu" as an option even with USB plugged in.

Clicking TAB to Application Menu and selecting "1. Diagnostic Screen" (the only option), I can see "USB Device: Kingston DataTraveler 3.0" listed.

Trying to enter the BIOS setup fails too. Pressing F12 doesn't open BIOS setup, it opens the Zorin menu, which shows:

Zorin
Advanced options for Zorin

And I can access the grub cli with "c", or edit parameters with "e".

My research seems to indicate Secure Boot may be the issue, but I can't access the BIOS to disable it.

The USB stick is the same device I used when installing Zorin, so it doesn't seem to be an issue with compatibility.

Any ideas?

Are you using Acer laptop?
I have exact the same key combination for BIOS and Boot select on my old /Acer Aspire.

I am using this laptop for dual booting Linux and Windows 10.

In general, it is preferable to Install Linux first followed by Windows, since Windows tends to think that it is the only OS exists on the system. If you search on the net you will find all sorts of horror stories about Windows overwrites itself on Linux bootloader made it un-bootable.

As for getting into BIOS, sometime the delay time which allows to hit function keys is set to very short. If that is the case, you really have to continuously tapping F2 key during booting.

I am not sure if many would agree with you on that point. We will see if anyone else has an opinion. The usual set-up is a Windows PC, onto which you add Linux as dual-boot. Noting the need to quash Secure Boot, to avoid the Windows blockade.

1 Like

Ah, of course. You got a point!

I only dualboot 10 years old Acer Aspire which has been flashed with a mod BIOS - no, it is not a normal setup :wink:

All other machines have either 16 GB or 64 GB of ram, making them feasible to run Windows as a virtual machine on them.
In fact, I found it is easy to install Windows as a virtual machine rather than installing it as dualboot.

1 Like

Thanks for your answers.

@FrenchPress I installed Zorin first already and have an empty parition for Windows to install in.

It's a Fujitsu Lifebook AH532. I have tried holding down F2 and clicking it super fast, but no luck so far!

It really reminds me of the situation we had a few years ago for HP Probook. I installed OSX on it for my husband but he wanted to go back to Linux. What I did not realize was that I inadvertently enabled Fast Boot and unable to go into BIOS.

We ended up a house call of "specialist" who managed to get into BIOS and disabled Fast Boot. It was a 60 Euro lesson I learnt :sunglasses:

Searching Fujitsu forum, I hit this thread:
https://forum.ts.fujitsu.com/forum/viewtopic.php?p=151855
The last comment by Fujitsu moderator might be helpful:

If that doesn´t work, you can press the F2 key first and then switch on the device while the F2 key remains pressed.<<

Sadly this has not worked.
I have tried holding F2 before I click power-off, then clicking power on whilst it is still held, I have powered off then held F2 whilst I power on, clicking as fast as I possibly can whilst powering on.
In all cases I hear the beep, but then the Zorin options menu appears.
When pressing F12 I hear the beep too, and get the Boot menu but, like I said, only ubuntu is listed.

It is very odd.

While I am not 100% for sure, it looks like the problem is not Zorin specific.

I looked around Ubuntu Forum (which Zorin is based on) and Fujitsu Forum. There seems to be a way to boot into BIOS from Windows environment, but I do not know such function in Linux.

Are there any chance you burn Windows installation DVD and try booting from it?

Did you try cold-boot?
Clicking power on/off is a soft-boot and does not have a same effect as a cold-boot.

I think your laptop is old enough to have a removable battery, no? If so, remove the battery to completely shut the machine first.

I found this 2 years old post at Ubuntu Forum:
https://ubuntuforums.org/showthread.php?t=2407207
The last posting might help you:

On doing some research, found out that this issue is specific to Fujitsu laptops, not sure why - but there are some threads where people faced similar issues for Fujitsu laptops dated long back in 2012 too. On Fujitsu laptop Ubuntu install somehow play with BIOS and alters it so that default BIOS screen is not shown and makes the user stuck on that screen with only option of "ubuntu", which too does not work.

See links below to similar issues reported earlier:
Bug filed on Ubuntu in 2015: https://bugs.launchpad.net/ubuntu/+s...x/+bug/1451387
Someone reported in 2014 13.04 laptop with EFI but cannot enter BIOS -- this thread saved my life. I followed instructions in this to reset the BIOS to factory settings by shorting-circuiting the pins on motherboard. After doing that when I started the laptop and it directly booted Ubuntu. Thank god I found that thread

Did you try using Boot Repair Disk I think is mentioned in one of those posts. You can find it on sourceforge.
That got me out of a problem back in my Z12.4 days.

Hi all, thanks for the responses. Sorry I've not responded, been busy this week so haven't been able to try the suggestions.

I'll have a go at some of them this evening

Updates for you.

After reading through and implementing the solutions in the threads provided I am still not sorted. It seems that there is a bug/incompatibility that causes the Bios F2 and F12 access to be broken when installing Ubuntu.

Fujitsu blame Ubuntu for messing with the BIOS stuff when installing. And the Ubuntu guys says Fujitsu's BIOS causes the issue. Also Fujitsu say they don't support installing any operating system except from Windows on the laptop, so they won't help. And besides it's well out of warranty. It seems that flashing the BIOS is the way forward.

The issue I have is I can't change the boot order at all to flash it via USB or CD, and flashrom doesn't support the laptop architecture. Fujitsu's bios tools are only available for Windows and DOS.

So last night, I attempted to configure grub2 to boot from a FreeDOS iso in the boot folder in Zorin. I tried both the FreeDOS LiveCD and LegacyCD isos. These both failed. I simply get a grey screen with dots all over it (very strange).

I then installed FreeDOS onto the USB stick using UNetbootin. Rebooted and tried to manually boot to FreeDOS from grub. This loaded the Windows Boot Manager but had the error: "A Required device isn't connected or can't be accessed" and wouldn't boot into FreeDOS.

I recognise that the only way to fix the BIOS and get dual booting working, is to plug the laptop HDD into my PC and wipe it and try to start again.

My plan:

  • Remove all partitions.

  • Create a 10GB partition, and split the rest of it between Windows and Zorin.

  • Using YUMI, install the Windows 10 installer into the 10GB partition.

  • Install HDD back into laptop and run the Windows 10 installer.

  • In Windows - download and run the Fujitsu BIOS flashing utility.

  • Reboot. Check BIOS is working now.

  • If it is, download create Zorin Installer USB.

  • Using Zorin Installer, move the Windows 10 partition to the beginning of the HDD, and absorb the 10GB Windows installer partition into the Zorin partition.

  • Install Zorin into the partition.

  • Reboot. Check if BIOS is broken again (probably will be!)

  • If it is, boot into Windows 10. Run the Fujitsu BIOS utility to flash it again.

  • Reboot. Check if BIOS is working again.

  • Check that boots properly.

  • If it doesn't run a boot repair tool.

Hopefully this might resolve my issues!

1 Like

I am a bit confused.
Do you have any operating system on your internal drive?

is a Windows error message - indicating you still have Windows on your internal drive.

I have (had) Zorin installed only. That message came up when I tried to boot to a FreeDOS LiveCD installed on a USB, from GRUB2.

So at the moment your internal disk has no OS?

Yes I have fully wiped the laptop's HDD. Just partitioning now.

A few years ago, similar thing happened on Lenovo laptop:

There was a lengthy discussion at launchpad and I remember helping at least 2 people to get their BIOS out of read-only status.

Unfortunately this kind of situation happens time-to-time since manufacturers test their products only with Windows OS and nothing else :frowning_face:

As a side note, I have a Gigabyte dual BIOS M/B on my testing machine. BIOS flashback function got me out of tight spot at least once.

I read and reread your strategy.
It seems a good one.

Please report back the results here. I am sure it will benefit feature readers coming here by searching for solutions.