Cannot add SD card as Steam library

Hey everyone. I'm trying to use a 16 GB SD card to store my Steam games, but selecting it gives me the following error.

New Steam library folder must be on a filesystem mounted with execute permissions

Here's a screenshot of the SD card in the Disks app.

After looking online for a fix, I think I mounted the SD card or something, and now Steam says "New Steam library folder must be writeable".

You might look at mounting it with full permissions, so that you can access it without having to grant permissions each time in the future:

I ran this command to unmount the SD card.

sudo umount /dev/mmcblk1p1

And then when trying to run the next command, I got "mount point does not exist".

sudo mount -o rw,users,umask=000 /dev/mmcblk1p1 /mnt/sd1

If you look under /mnt, there are no subdirectories unless something is mounted. It will automatically add the device id as the subdir, you don't have to. Change /mnt/sd1 to /mnt and it should work.

Now I got this.

special device /dev/sdb1 does not exist.

If you type mount --help, does it say the mount point is first or the device? You may have their placement backward.

 mount [-lhV]
 mount -a [options]
 mount [options] [--source] <source> | [--target] <directory>
 mount [options] <source> <directory>
 mount <operation> <mountpoint> [<target>]

mount <operation> <mountpoint> [<device>] is the one you want to use. Transpose the mount point and target/device.

/mnt is the mount point

To define them in a different order you have to use the flags --source and --target respectively.

You could have opened disks and modified the mount permissions there i believe.

You have mount at system startup. You will have to get the octal for those permissions and add it to the /etc/fstab file.

Why didn't you just transpose the device and mount point in the command you were using. It would have worked then.

Because I don't even know what a mount point is or how this command works.

I just told you.

The mount command places a symbolic link in the mnt directory to the device you are mounting. The mount point is where this link will be located and can be anywhere your user has access to it. The most common is mnt. The device is listed second while the mount point is listed first.

This, like anything else you learn, will take time, reading, and trial and error.

Use the same command you did before but switch the /dev and /mnt entries.

All this is covered in a web search easily.

You can't mount something already mounted so be sure to unmount it from disks first.

In disks there should be a field marked mount options that takes text. You can place the -o and permissions there also.

In Linux, everything is set your command. Things are still done behind the scenes, so to speak, as that's how it's done, but all can be configured as you see fit. Something ms won't allow you to change. It will take time, research and dedication to gain understanding and confidence, as with anything else. If you want it to just work, this isn't for you. If you want control over your computer instead of giving it to someone else that farm's your information and sells it for ads, then Microsoft or Apple are your OS's. Keep at it and you'll get it, but it will take work.

I mounted the SD card at /mnt/sd but now the card got a weird name in the files explorer and clicking it doesn't do anything.

It's mounted at a different directory now for some reason.

It's mounted in /mnt. Looks like it's using the type and model for the dynamically generated symbolic link (mmc-...). Mmc is the type of media. Had this been a thumbdrive it would say usb (unless it was a name brand, then it's usually the company name).

Did you copy the steam folder from a directory in windows? Did you eject the media before pulling it?

In windows, after a copy, the OS includes the directory/file(s) you just created to the search index (a process that can take some time after your done copying it). Also, antivirus programs like to evaluate what was just created (even windows defender). If you pull the media while it's being accessed it can and does wipe out whatever you copied.

Always eject the media prior to pulling it out. If that doesn't work, shutdown the computer (still being accessed and refused your request to eject)

Please keep in mind that not all games work in Linux, of any variety. The latest and greatest won't (destiny 2 is one of them). Even then you will either have to use lutris or steam Proton compatibility to run some of them. This is why i dual boot.

I created the Steam folder right in the SD card. And no, I didn't eject the card. I'm not used to ejecting stuff, as I just assume it's not in use after a couple minutes of inactivity.

And why was it mounted in a different directory (/mnt), when I specified /mnt/sd in the terminal command?

Wait. It's mounted in /mnt/sd now. But I don't understand how to make it get that name instead of "Library" which is the partition's name. If I unmount and mount it using the Disks app, it does get the "Library" name and a nice SD card icon.

I messed around with the mount options in the Disks app and managed to give it a display name and icon.

But the main problem is still there.
Clicking the SD card simply shows a "loading" animation next to it for like a tenth of a second, and never actually opens the SD card in the files explorer.