Cannot boot back into Zorin OS after booting into Windows 10 once

I don't, it was automatically added to my boot order as I installed Zorin, and labelled as "ubuntu".

I can't, my problem is still as I described im my original post.

Their answer was along the line of "Do whatever you want, we'll just reinstall Windows when it inevitably crashes". Well, I'm one OS down so far, hoping the second doesn't follow :grin:

What happens if you reinstall Zorin OS? :expressionless:

Over confident. Millions of users are successfully using Zorin OS / Linux.

I might have to, I has spent quite some time configuring Zorin and I was hoping to salvage it somehow.
But I believe simply reinstalling might not solve the root of the problem, and next time I'll boot into Windows it will stop working again.
It's kind of a shame, I just needed to export some data from Windows to bring everything back to Zorin, I might not have noticed the issue for months otherwise, as I don't really use any Windows-specific software for now.

Did you run grub repair from the Download or from the Live Disk?

I ran it from a Live version on a bootable USB.
It resulted in this :

I also tried booting into recovery mode, here :

I think the only option I haven't tried is fsck, I'll give it a shot.
The GRUB itself seems to work just fine.

Why not?

But I wasn't clear, sorry. I meant, while in the Live USB, did you download and run Boot Repair or install boot repair? Then run it?

This problem I have before. You mean you see loading system Zorin logo and name and then black screen? It is problem with drivers graphic card.
The configuration Zorin what is not the same what windows. Some people know me here if I find some problem what not working on my PC i take a battle. When I win I am very happy to learning new things in Linux where I decide what will be inside. Windows is something like hoary old chestnut. We know also all laptops and PC mostly are building for operating system M$ and apple. That why if we want we install linux better check on webside (i know exist)where you can find your parts what has a drivers.

[SOLVED] "Locked Nvram detected" / API issue on reboot (Elementary and Mint) | maybe this help little

1 Like

I didn't work when I tried, I believe running dpkg beforehand put the disk into read/write mode, and fsck requires the disk to be in read-only.

Boot Repair was already installed, I just looked it up in the launcher.

Yes, I suspected that. Can you try using the method in the link I posted above, instead?
If it fails, it gives an output with a log file. If so, please post that here.

The screen isn't black, it's just stuck on the Dell startup logo. I don't think it's a matter of GPU drivers, the OS just won't start.

Regarding your second post, some issues are similar, but the thread ends by the original poster saying his problem magically disappeared after a few days, which is strange.

So I first tried fsck in recovery mode, and it simply said something along the lines of "e2fsck : Cannot continue, stopping now".

Then I booted into the live version, and followed the method you linked to.
Since it pointed to a specific repository and Boot Repair was already installed, I first removed it then reinstalled it just in case that repository contained a slightly different version.

Boot Repair proceeded as before, stopping because of "Locked NVram".
Here's the pastebin of the log file : boot repair -

1 Like

Are you set in BIOS settings to RAID or to AHCI?
You should be set to RAID in order to install Zorin OS.

Welp, that might be an issue.
My computer uses Intel RST, which prevents Zorin from installing.
I actually went through some trouble, and a few Windows Safe Boot loops to set my computer to AHCI because I couldn't install Zorin otherwise.
The Zorin installer itself stopped early on and directly pointed to the Ubuntu help page with instructions on how to switch to AHCI.

This gets complicated.

Generally, yes - it should be set to AHCI.

However, I could see in the pastebin log that you are using nVME - for which it must be set to RAID.

I just did some cross checking on various sources to be sure...
I think... you may be in for a hard time of it. You have a situation where each works against the other.

There was a time, not too long ago even, when the general agreement was that Linux cannot properly be installed on eMMC or nVME at all. Things have improved in the last two years.
But RST plus Nvme is a bigger problem.

Well that's a shame.
It's especially strange since Zorin worked just fine for a while, and booted on and off multiple times.
There must be something that Windows has done while starting up that messed up the install.

I know very little about Windows 10 - and I hesitate to speculatively try to help as it may mislead you.

I understand this might be out of the scope of this forum.
I might try and ask on general purpose Ubuntu forum, and see what they say.
I assume switching back to RST after Zorin was installed in AHCI isn't a good idea.
And I don't believe enabling RAID without RST is possible.

I know that trying to enable RAID without RST is beyond my scope, at least. And even if possible, may be like balancing a ball on the end of your nose. Unstable.

In hindsight - I wonder if this is that the IT guys were thinking about when they made their comment...

I don't think they're even aware of the type of computer I'm using, let alone details like this one.
I also checked my personal computer last night, on which I was planning to install Zorin as well, and it made me think of this :

That laptop uses nVME, and is configured in AHCI out of the box.