Cannot boot back into Zorin OS after booting into Windows 10 once


I recently installed Zorin OS 16 on a Dell Latitude 5510 with Windows 10 already installed.
Zorin OS worked just fine until I had to boot back into Windows once, after which it refuses to start.
More precisely, after the GRUB shows up and I select Zorin OS as a boot option, I see the Zorin name and logo appear for a while under the Dell logo, then the former disappears and the computer is left stuck on the Dell startup logo.
Is there a way to salvage the install ?

At the grub menu, try the advanced options -> then the terminal (prompt) entry. There you can run:

1 Like

Another way is to boot the live cd, choose the something else option, choose your bootloader location.... In the top window choose the ext4 partition and hit the gear. Mount on / do not format. Mount any other partitions you had originally after that also without format. Hit install.

1 Like

Also ensure that when you went into Windows, the Fast Startup setting was not enabled. I believe it is the Control Panel - power settings.

1 Like

grub command prompt says it cannot find 'boot-repair' command.
I will check if I still have my bootable USB and try the other solution.

Thanks, I checked and it was already disabled.

1 Like

Update :

I've tried a few more things, to no avail.

does not work (as in, command not found) on both the GRUB command prompt as well as the root command prompt when I try to boot into recovery mode.
While in recovery mode, I tried updating the GRUB and fixing broken packages.
I also took a picture of the partition layout, if that can be of help.
When I proceed with boot, I just get stuck on a black screen until I press the Power butto, at which point a few lines of text appear and the computer shuts down.

You might try running boot repair from the live medium. Open the live session and search boot repair. You'll have to look at the options carefully since the cause of the problem is unknown.

1 Like

I assume boot-repair isn't installed by default since I the root command prompt did not find it ?
I've quickly looked at the docs for boot-repair, is it risky to just run it with default options, at least as a first try ?
I'm still not very knowledgeable about handling boot and partitions.

1 Like

Default options should work for you. Boot repair is installed by default, but you may have to mount the root partition to access it. More than i was planning on doing.

The only other thing i can recommend is to reinstall the bootloader. You can do this without reinstalling the os by booting the live image, click install, use the something else method. When you get the partition window, underneath it asks for bootloader location, choose the windows efi partition (100mb named efi). In the partition window at the top choose your ext4 partition (whatever size you chose) select it with a single left click and hit the gear under the partition window. Mount it at / choose the file system, ext4, do NOT format. Select any other partitions you are adding and choose the mount point. If there is a swap partition it will be ext4 same size as your ram. Do not format any of them. Then click install. That will rewrite your grub onto the drive.


I ran boot repair with default options a while back and it worked for me at that time with no side effects.

I ran boot-repair from the live version as suggested here

And it apparently found the culprit : Safe Boot enabled, NVRam locked.
I do remember reading that Zorin was Safe Boot compatible, but if I just have to disable it that's not too much of a problem.
I wonder if it will cause problems with booting on Windows ?

1 Like

It shouldn't. Windows can be finicky, but it's worth turning it off and trying.

You've got it.
No, Safe boot is not compatible - Zorin OS can mostly run with Secure Boot; but it is still recommended to turn Secure Boot Off on Linux machines as it still can interfere with independent apps.

I tried turning it off, Windows boots just fine, but Zorin still won't.
I ran boot-repair from the live version again, and I still get the Locked-NVram message.
From what I can see online people describe it as an hardware issue, encountered during setup, that is fixed by physically resetting something on the motherboard or flashing the BIOS.
But it's still puzzling that Zorin ran just fine for days, and only had issues after I had to reboot in Windows.

Is IOMMU enabled in your BIOS settings?

You might try booting with the grub parameter:
intel_iommu=on or intel_iommu=soft

I looked into it, seems like Intel refers to it as VT-d.
I checked that my processor is compatible with it, and nothing in the BIOS has that exact name, but there's something called "VT for Direct I/O" and I believe that's what they use for IOMMU. It is enabled.
I checked a few more options : while I disabled Safe Boot, there's something called UEFI Boot Path Security, should it be disabled as well ?
I also disabled Fast Boot within Windows itself, but there's also a Fastboot setting in my BIOS, could that interfere with boot ?
And lastly, just to check, the boot option for Zorin in my BIOS is


Is that correct ?

Very smart checking. EFI/BOOT/bootx64.efi might be preferred.
Ensure that Secure Boot is disabled.

ah... I have no idea. I never heard of one in the BIOS until just this moment.:expressionless:

You could try it out and see what happens. Most scientific explosions are caused by "I wonder what happens if I do this."

It's also the primary cause of me reinstalling O.S. :expressionless:
Be fearless. :smiley:

So I tried adding

at the top of my boot order. It failed to boot and skipped to the "ubuntu" option where my GRUB is located.
I tried disabling "Fastboot" in the BIOS as well, but nothing changed.

As much as I would like to be, this is a work computer, so I'm going to try to keep the explosions at a minimum :upside_down_face:
IT was kind enough to let me install whatever I want on that computer, but I don't think they would appreciate me accidentally bricking the entire machine.

Interesting... Well, I guess revert that back. But now, I am confused... Do you have Ubuntu installed as well?
That might explain the above...

Are you able to boot into Zorin at all?

Fortunately, there is not a lot you can do that can brick it... But refrain from ever using the rm -rf command at all. :smiley: That is an unusual IT dept. that allowed you to install Zorin. :open_mouth: